WebLogic 12c and JRockit compatibilty

Soumen

Reputable Poster
I am trying to install WebLogic 12.1.3.0 with JRockit R28.2.7 (JDK1.6) but the installer does not launch and throws a message saying ... "UnsupportedClassVersionError". I have checked the Certifications for WebLogic 12c and it does not list JRockit under the supported version unlike Oracle JDK.

My question is can I still use JRockit with 12c? If yes what version should I be using? I already did a successful install with Oracle JDK 1.7 but I wanted to use JRockit with WebLogic.

This is a Windows 2012 R2 on 64bit installation.
 

altquark

Legendary Poster
Nope. JRockit is no longer supported by Oracle. All the code for JRockit was incorporated into the Oracle JDK some time ago. Believe me, its not worth trying to get jRockit to work anymore. It was awesome a few years ago - but its out of support now.
 

Soumen

Reputable Poster
Nope. JRockit is no longer supported by Oracle. All the code for JRockit was incorporated into the Oracle JDK some time ago. Believe me, its not worth trying to get jRockit to work anymore. It was awesome a few years ago - but its out of support now.

Great! Thanks for confirming Jon.
 

altquark

Legendary Poster
BTW - even though its not "certified" - i actually install Weblogic 12.1.3 on the latest JDK 1.8 with no issues whatsoever.

Its worth patching your Java JDK to the latest - it should always support running weblogic of any version. Oracle pushes updates to Java all the time - so its important for security sake to keep it patched.

Now, although Weblogic 12.1.3 has already been superceded with Weblogic 12.2.1 - I haven't finished my testing of the new Weblogic version yet - and I don't think it's going to be certified until EnterpriseOne Tools 9.2.1.x - probably by Collaborate time perhaps ? So, stay with Weblogic 12.1.3 on JDK 1.8.x and you'll be fine.
 
Top