• Introducing Dark Mode! Switch by clicking on the lightbulb icon next to Search or by clicking on Default style at the bottom left of the page!

Unable to validate against E1local on Dep server

Hello List,

I am unable to login to JDE on the DEP server with below error-

<Jde.log>- OCI0000141 - Error - ORA-01017: invalid username/password; logon denied

While working with Oracle, we tried several things;

1. Doc ID 1138805.1

simple SQLPLUS sign in against SYSTEM/ADMIN/SYS to the E1Local database we received a simple error in the jde/jdedebug logs concerning "invalid Password .. access denied. "

nothing more in the log

2. Attempted twice to access ReconfigureMSDE.exe. which started up fine, but would not take any of the passwords listed for "System" to un-encrypt the database password to get back in.

same thing in the logs - invalid userid or password.

3. Attempted simple access to SQLPLUS using both SYSTEM, and JDE .. NOTE that SQLPLUS failed to access the database again using the same users, and passwords.

4. Finally tried the recommended action in Doc ID 1064181.1 E1: DB: How to Recover Lost or Corrupt SYSTEM/SYS Password in Local Oracle (OEE) Database
steps from the doc-


  1. Navigate to the OEE directory and locate the sqlnet.ora file. It should be located in the path
    E1Local\network\admin.
  2. Change this file (sqlnet.ora) and set SQLNET.AUTHENTICATION_SERVICES=(NTS).
  3. Restart the OEE E1Local instance.
  4. Login to the machine with an administrator account.
  5. Connect to the local database using "sqlplus / as sysdba" from the C:\Oracle\E1Local\Bin directory.
  6. Run the SQL command: Alter user system identified by admin;
  7. Now exit sqlplus and run ReconfigureMSDE.exe. You will now be able to encrypt the password for SYSTEM/SYS.
  8. Go back and disable the NT authentication in OEE by setting the SQLNET.AUTHENTICATION_SERVICES=(NONE) in the same sqlnet.ora.
  9. Restarting the E1Local instance is required.

This also failed on step-5, from the cmd prompt-



D:\Oracle\E1Local\BIN>sqlplus / as sysdba


SQL*Plus: Release 12.1.0.2.0 Production on Wed Feb 22 14:52:20 2017


Copyright (c) 1982, 2014, Oracle. All rights reserved.


ERROR:
ORA-01017: invalid username/password; logon denied


I am still working on it with oracle support but any ideas??

Thanks in advance.

-Anu
 

DEA

Active Member
Hello List,

I am unable to login to JDE on the DEP server with below error-

<Jde.log>- OCI0000141 - Error - ORA-01017: invalid username/password; logon denied

While working with Oracle, we tried several things;

1. Doc ID 1138805.1

simple SQLPLUS sign in against SYSTEM/ADMIN/SYS to the E1Local database we received a simple error in the jde/jdedebug logs concerning "invalid Password .. access denied. "

nothing more in the log

2. Attempted twice to access ReconfigureMSDE.exe. which started up fine, but would not take any of the passwords listed for "System" to un-encrypt the database password to get back in.

same thing in the logs - invalid userid or password.

3. Attempted simple access to SQLPLUS using both SYSTEM, and JDE .. NOTE that SQLPLUS failed to access the database again using the same users, and passwords.

4. Finally tried the recommended action in Doc ID 1064181.1 E1: DB: How to Recover Lost or Corrupt SYSTEM/SYS Password in Local Oracle (OEE) Database
steps from the doc-


  1. Navigate to the OEE directory and locate the sqlnet.ora file. It should be located in the path
    E1Local\network\admin.
  2. Change this file (sqlnet.ora) and set SQLNET.AUTHENTICATION_SERVICES=(NTS).
  3. Restart the OEE E1Local instance.
  4. Login to the machine with an administrator account.
  5. Connect to the local database using "sqlplus / as sysdba" from the C:\Oracle\E1Local\Bin directory.
  6. Run the SQL command: Alter user system identified by admin;
  7. Now exit sqlplus and run ReconfigureMSDE.exe. You will now be able to encrypt the password for SYSTEM/SYS.
  8. Go back and disable the NT authentication in OEE by setting the SQLNET.AUTHENTICATION_SERVICES=(NONE) in the same sqlnet.ora.
  9. Restarting the E1Local instance is required.

This also failed on step-5, from the cmd prompt-



D:\Oracle\E1Local\BIN>sqlplus / as sysdba


SQL*Plus: Release 12.1.0.2.0 Production on Wed Feb 22 14:52:20 2017


Copyright (c) 1982, 2014, Oracle. All rights reserved.


ERROR:
ORA-01017: invalid username/password; logon denied


I am still working on it with oracle support but any ideas??

Thanks in advance.

-Anu
You need to add your admin account to the ora_dba group in local users and groups on the server.
 

JDEE1Tips

Well Known Member
You need to add your admin account to the ora_dba group in local users and groups on the server.
Adding to above point ,

> Make sure to open the command Prompt as Run As administrator

> Recheck whether the Sqlnet.ora under E1local DB is SQLNET.AUTHENTICATION_SERVICES=(NTS).

> make sure to execute the Sqlplus / as sysdba from E1local Bin directory
 
Top