Unable to Preview Reports in RDA

Devki

Active Member
We are on E1 Xe update 7 with SP23_K1 on the DB2/400 iseries Enterprise Server.

We are running adobe 8.1.2 on all the desktops and earlier version of adobe reader was removed. We now have a problem previewing reports in RDA during the development stage. Preview shows a blank screen even though preview.pdf gets created in the Printqueue directory on the fat client.
This problem is only when using Preview Report in Report Design Aid (RDA) on a Fat client. Otherwise pdf opens fine in Adobe 8.1.2 from OMW or Batch versions list or even from the PrintQueue folder. Looks like RDA does not associate with Adobe 8.1.2 to launch the pdf.

I have standard version of Adobe 8.1 (Reader/Writer) on my machine and I am able to preview a report from RDA (other machines only have the Adobe reader 8.1.2) and also we have Adobe 8.1 on the Citrix Server which tells me that the Adobe version is compatible with Xe.

Has anyone stumbled across this issue?
Thanks
Devki
 

Wendell

Active Member
Devki,

Yes, I ran into similar problems early on and no longer use preview. Instead I run using advanced > location override > local > submit. When you do this you should notice a local instance of the UBE running and when it's done the pdf/Adobe app loads with the results. The same can be done for CSV output and whatever your default app for CSV is will run with the result.

Regards,

Wendell
 

Segfault

Reputable Poster
Not sure you'll be able to fix that -- RDA loads preview using a COM interface id, and I think at some version of Acrobat, they changed the ID, so the only way is to get a newer version of JDE than XE SP23_K1.

(edit -- didn't realize I was posting to a 'necromanced' thread from 2008. Not sure why NandChavan thought this was a good idea)
 
Top