• Introducing Dark Mode! Switch by clicking on the lightbulb icon next to Search or by clicking on Default style at the bottom left of the page!

Unable to Log into JDE using Network Load Balancing (NLB) with Weblogic 11g

Prathiba

Active Member
Hi - I am posting this on behalf of our CNC...

We are looking for some suggestions on why this is happening. So here it goes:

We currently installed the basic version of Weblogic 10.3.5, with JDK 1.6.24, however, not being familiar, we read a lot of the documentation online for the setup. Our configuration is set up as follows --- Two Weblogic servers, running on Windows Server 2008 R2, 64bit, setup two separate JDE Production JVMs – Port 85.
Our Network Team installed and configured the NLB cluster on both servers, which for our test, called it cssjde_cluster.css.corp. This NLB cluster is set to Multicast, and includes both of our WLS servers. They made an entry in the DNS to include cssjde_cluster with the IP addresses of our WLS Servers. Our test link given was http://cssjde_cluster.css.corp:85/jde/owhtml
Get ready for the mind blowing piece of this test --- when we click on the test link above, using Chrome/Firefox, our JDE log-in screen displays, users are able to log in, stay assigned to that WLS server, we see their activity using our Server Manager Tool, and NLB seems to be working as it should. HOWEVER, when we do the same steps using Internet Explorer (any version, 11, 10, 9), our JDE log-in screen launches, but when we try to sign in – JDE tries, and then returns back to the JDE log-in screen, clearing the user ID information, with no errors. I did look to at the logs through Server Manager since we do see the user attached to the server, but the logs are normal.
So we are stumped… Is this an IE security issue? Is this a security issue with our WLS servers? Is this an issue with how the NLB is set up? Please provide your thoughts on resolving this.

Thank you very much for your time and input!!
Prathibha Hanumali

Version Information:
E811 SP1 Tools Release 898.4.7
WLS 10.3.5
JAVA 1.6_24
2008 Windows Servers – R2, 64 bit
2008 Windows Server Network Load Balancing Standard, Version 6
 

78aspide78

VIP Member
Is this an IE security issue? Is this a security issue with our WLS servers?
Try to access to JDE with IE outside the NLB (just point to the original url); if it works with both url then try to set the IE security settings to the lowest value.

May be the session is not maintained between browser request (cookies setting in IE).

Regards

Bruno Condemi
 

Prathiba

Active Member
Thank you for your valuable input. We have tried the individual urls to specific server and they work. As you suggest, we will lower the security settings and test.

Is there a way to force cookies to retain the session parameters?

Thanks,
Prathibha
 

altquark

Legendary Poster
Make sure you set your IE to compatibility for the load-balanced website.

Also, make sure that you configure your IE registry settings - there are posts on this forum you can search for that will help you. Just look for "IE+registry"
 

Prathiba

Active Member
Thanks Jon and Bruno for the responses.

We have found the root cause of the problem and it is the "underscore" in the domain name that was setup!!!

Check this: http://www.schwammysays.net/problems-with-underscore-in-urls/

Once we renamed it to a name without the underscore, NLS is working as it should and we are able to signin :)

Thank you very much for all your help in resolving this conundrum.

Best Regards,
Prathibha
 

altquark

Legendary Poster
Oh - thats an old issue - glad you posted an update, I missed the fact you had an underscore in your server name ! Its bad practice to use underscores on any web-based systems - I totally have a policy these days of making sure NO underscores are used anymore in ANY servers !
 
Top