• Introducing Dark Mode! Switch by clicking on the lightbulb icon next to Search or by clicking on Default style at the bottom left of the page!

Unable to locate table in specified datasource for section

Sbau

Member
Hi all,

I have this specific UBE that is quite simple: it reads F3002 from a data selection set in the Initialize Section, then does a few inserts in the Do Section and finally launches another batch (in the End Section).

My problem is that sometimes, the batch ends in error. It's quite random. If I relaunch the batch on the same data selection, the error doesn't happen again. Please note that the batch is run on the enterprise server from a scheduler command.

When I look at the logs, here is what I find - the batch tries to read F3002 (main SQL requests between the Initialize Section and the Do Section), but it failed to do so... It then stops and doesn't go into the Do Section nor the End Section.

***

Sep 01 20:11:44.514233 - 10060/10036 Entering JDB_SetSelectionX (hRequest 07582260)
Sep 01 20:11:44.514234 - 10060/10036 Exiting JDB_SetSelectionX With Success
Sep 01 20:11:44.514235 - 10060/10036 Entering JDB_SelectKeyed (hRequest 07582260)
Sep 01 20:11:44.514236 - 10060/10036 ODBC:S DBInitRequest(new) req=0748DE98 con=016EE430 env=015E7678 dbc=015E76F8 spid=62 CRZFJDE05 A (JDEUSE@CRZFJDE05 - JDE_PRD)
Sep 01 20:11:44.514237 - 10060/10036 SELECT * FROM JDE_PRODUCTION.PRODDTA.F3002 WHERE ( ( IXTBM = 'DT' AND IXUPMJ >= 117244 ) ) ORDER BY IXKIT ASC,IXMMCU ASC,IXTBM ASC,IXBQTY ASC,IXCPNB ASC,IXSBNT ASC,IXCOBY ASC
Sep 01 20:11:44.514238 - 10060/10036 Entering DBPerformRequest
Sep 01 20:11:44.514239 - 10060/10036 ODBC:S DBPerformRequest req=0748DE98 con=016EE430 env=015E7678 dbc=015E76F8 spid=62 CRZFJDE05 A (JDEUSE@CRZFJDE05 - JDE_PRD)
Sep 01 20:11:47.810000 - 10060/10036 ODBC[jdbodbc.C,7856] wSQLExecute failure. rc = -1
Sep 01 20:11:47.810001 - 10060/10036 ODB0000163 - wSQLExecute failure. rc=-1
Sep 01 20:11:47.810003 - 10060/10036 Exiting DBPerformRequest
Sep 01 20:11:47.810004 - 10060/10036 JDB9900401 - Failed to execute db request
Sep 01 20:11:47.810006 - 10060/10036 Exiting JDB_SelectKeyed with Failure
Sep 01 20:11:47.810007 - --UBE--[0]-- Unable to locate table in specified datasource for section: Bill of Material Browse
Sep 01 20:11:47.810008 - --UBE--[2]-- Finished with UBE Message Loop
Sep 01 20:11:47.810009 - --UBE--[1]-- Total Pages processed are 0
Sep 01 20:11:47.810010 - --UBE--[6]-- Printing Object Value = 'No Data Selected'
Sep 01 20:11:47.810011 - --UBE--[6]-- Printing Object Value = 'ERROR:'
Sep 01 20:11:47.810012 - --UBE--[6]-- Printing Object Value = 'Unable to locate table in specified datasource for section: Bill of Material Browse '
Sep 01 20:11:47.810013 - --UBE--[1]-- Before PRT_EndDoc
Sep 01 20:11:47.842000 - --UBE--[6]-- Unsuccessfully Finishing Engine. Review UBE log for errors.
Sep 01 20:11:47.842001 - 10060/10036 Closing cached JDESPECTYPE_SVRDTL handle.
Sep 01 20:11:47.842002 - 10060/10036 DestroySpecCache() - Destroying spec cache for spec type, JDESPECTYPE_SVRDTL
Sep 01 20:11:47.842003 - 10060/10036 Entering jdeCacheTerminate
Sep 01 20:11:47.842004 - 10060/10036 hCache:[0879F858] Nm:[0JDESPECTYPE_SVRDTL CACHE-HANDLE-73c3078] Recs:0 Curs:0 Hnds:1 Cchs:2 TERM one
Sep 01 20:11:47.842005 - 10060/10036 Decremented cache count to 1

***

Of anybodys knows what happens, it would be great !

We are running JDE E920, with 9.2.0.7 tools.

Many thanks,

Samuel
 
Top