• Introducing Dark Mode! Switch by clicking on the lightbulb icon next to Search or by clicking on Default style at the bottom left of the page!

UDC through ODA

bazscott

Member
Hi list,

We are trying to use a VB app to access various tables through ODA which is working fine on all tables (F0901, F0010, etc) apart from when we try to get to the F0005 UDC table. All that comes back is every field marked as #deleted !! Has anyone else experienced this, and figured it out, hopefully?

cheers
barry

Working at Miller Group, Edinburgh, Scotland
OneWorld Xe sp13 - Oracle - on Solaris and NT
 

Larry_Jones

Legendary Poster
Barry,

Are your UDCs (F0005) mapped to the server or local with replication? I'm not sure how ODA handles tables that are mapped local.

Another more likely cause of the problem is that in the "OneWorld ODA" DSN you have the "Convert User Defined Codes" option checked. If so, turn this option off and try again.

Regards,

Larry Jones
ljones@wagstaff.com
OneWorld B733.1, SP 11.3
HPUX 11, Oracle SE 8.1.6
SandBox: OneWorld XE
 
Barry,

I haven't used ODA in this manner but I think this is due to the Table Owner
being CTL instead of DTA eg CRPCTL /CRPDTA.

This may explain it as the files you quoted are all DTA ie Business Data and
the F0005 is Control Data. Possibly Hard Coded within ODA?

Regards

Colin Docherty
REP7 Limited



-----Original Message-
 

bazscott

Member
Re: RE: UDC through ODA

Larry, you were right - found that out about one minute after posting :) Turning off the obdc setting fixes it.

Col - How you doing? Good to hear from you again, I'm back from Hong Kong and working with your mate Mr Quinton, drop me an email and let me know how things are with you.

cheers
barry

Working at Miller Group, Edinburgh, Scotland
OneWorld Xe sp13 - Oracle - on Solaris and NT
 
Top