E9.2 UBE results local vs. web server


Active Member
JDE Version: 9.2
Database: Oracle 19C

A custom Driver UBE calls three separate UBEs synchronously to populate data into work tables. Then a custom NER is called to clean up a work table and reload the data into the work table by processing the data loaded into the work tables from the first three called UBEs.

When I run the Driver UBE locally all data is processed successfully - applicable SOs with their associated line items. When I run the Driver UBE in the lower environments on the web server, there are missing line items for only one of the SOs, and it's inconsistent, e.g. Job run one, LNID 1 exists, but LNID 2 through 8 are missing. Job run two, LNID 1 and 4 exist, but 2, 3, and 5 through 8 are missing.

I've compared the code on my local machine with all environments DV, PY (UAT), and PD. It all matches. I ran the the 3 UBEs from the Driver UBE minus the NER and all of that data matches in the work tables whether I run it locally or on the server which leads me to believe there's an issue with the NER. But if that is the case, why does it run without any issues on my local machine vs. on the server?

Does anyone have any ideas as to why this might be occurring because I'm fresh out?


Do you know if it's the UBEs that are not adding the LNIDs. Or is it the NER that's cleaning them up wrong?

It's hard to debug on the server, so maybe add a new processing option to your driver UBE to call/not call your NER and check the state of the table when you don't call it.
That should help you narrow down where the issue lays. In the UBEs or the NER.

What does your job log say? Are you spotting any duplicate key errors etc
There is a chance that the NER was not deployed & built properly on the server. We had faced a similar issue with a custom NER where it was working perfectly locally but when user tried to run the report, the NER didn't return any values. We found this out through logs. You should also take the logs from server and analyze them, high probability that your NER was not built successfully.