• Introducing Dark Mode! Switch by clicking on the lightbulb icon next to Search or by clicking on Default style at the bottom left of the page!

UBE Japanese Vocabulary Override not showing up on PDF

KevinCourtney

Active Member
Hello,

I've added Japanese Vocabulary Overrides for the "J" type language preference to my custom UBE, see the attached screen shot (1) .

I've logged in as a Japanese user and run the UBE locally and I don't see the Japanese text from my overrides, see attached screen shot (2). I've highlighted the easier ones to identify. I've tried deleting the six data dictionary files, restarted JDE a couple of times, and no difference. I do see the Japanese names printing on the PDF, so that tells me it's recognizing the "J" type language, otherwise it wouldn't have the font set.

I'm waiting for an update package to be deployed to see it makes a difference but I would hope that we can test the vocab overrides overrides locally.

I've just arrived in Japan to demo my stuff, have several UBEs and Apps to add Japanese overrides....so hoping I can figure this out and show them some Japanese text.

Any ideas of what I'm missing?

Thanks, Kevin
 

Attachments

JEMILLER

VIP Member
Kevin,

Vocab overrides modify central objects specs directly. This is why there is that warning in the application, something like ~ changes will override checked in objects ~. You definitely need the update package to get the changes active on the server.

For local, have you tried doing a get of the UBE to your local workstation?
 

KevinCourtney

Active Member
Justin, thanks for the reply. I just did the "get" and that did fix the problem for both the UBE and App. Since I could see the vocabs overrides in the vocab override screen, it never occurred to me that I had to do a "get"...live and learn.

an update package didn't fix the web issue (non-local) but in discussing it, sounds like we have to do a full package to make the vocab overrides stick.

You came through, thanks for the help,

Kevin
 

JEMILLER

VIP Member
Kevin, that is goods news. I am glad I could help. デモをがんばって!

On the update package, the updated UBE specs will be merged into the parent package and the associated serialized objects for the updated objects (in F989998 and F989999) will be deleted on deploy to allow them to regen.

When the update package was assembled was the J language ticked? That would be a common reason why the overrides wouldn't come through. You would need to select the J language on a full package as well or it will not deliver the language overrides.

I would be embarrassed to say the number of times I have had to restart a package build because I forgot to tick required languages. At one site with 8 languages I just modified the package assembly application to select the needed ones by default.
 
Top