UBE fails with rcode=0


Active Member
HI All,

Whn I submit UBE on server it fails with following error message:

5001 Thu Aug 28 08:45:08 2008 runbatch.c383

5001 Thu Aug 28 08:45:08 2008 ipcpub.c3133
process 5001 <runbatch> registered in entry 23

5001 Thu Aug 28 08:45:08 2008 runbatch.c633
Startup for User=GINOTRA, Env=PY7333, Job#=4664249

5001 Thu Aug 28 08:45:11 2008 combined.c344
RDEL0000045 - Could not open tables for reliable event delivery (F90703 and F90704). Reliable event delivery will be disabled

5001 Thu Aug 28 08:45:12 2008 runbatch.c1150
RUNBATCH: Remote CP=1252, Remote OS=5, Local CP=1252, ConvertToASCII=0

5001 Thu Aug 28 08:45:14 2008 ipcpub.c3514
API ipcSawUnregisterProcV1 : process 5001 unregistered in entry 23

5001 Thu Aug 28 08:45:14 2008 runbatch.c1422
Job of type UBE failed with rcode = 0

It is UBE and environment specific environment. Othe rUBE woks fine in this environment and this works fine in other environment.

Setup # Xe, Sp22_n1, unix,oracle9.2.0.7

please help.



Legendary Poster
Your symptoms suggest that the specs for this UBE are probably corrupted on the server. Try building and deploying an update package with the UBE and its versions, or submitting the specs only when you submit the UBE to update the specs on the server.


Active Member
Thanks Ken.


VIP Member
I get the same error while deployed to the test server.

Job of type UBE failed with rcode = 0

This report works fine when launched from the fat client.

I have tried the below steps.

1. Re-deployed the object many times ( in an update package)
2. Cleared the report cache
3. Checked-out, checked-in, and then deployed in updated package.

Unfortunately, I cannot do a full package deployment right now.
What is the alternative solution ?


VIP Member
I have copied this report to another report and deployed. But the new report also ends in error status.


VIP Member
Hello Tom,

I was thinking JDE would give some hints on the issue. But it just stated the above message and kept mum ( because of the debug loglevel)

To find the issue, I used another fat client (I did not get specs of all the related objects, but just got for major object).
And finally I found one business function is not deployed to the test server.
I deployed it and now it's working.