E9.2 Trouble with Insert Grid Buffer Row in Chrome and Edge

jlanawalt

Member
We have a custom interactive application with a Col Exited & Changed - Inline event rule on a Grid on a Headerless Detail Form where if the quantity is not zero and if the item number (previous column) matches some criteria, we add one or more additional rows via Insert Grid Buffer Row(FC Grid, VA evt_n55GridRowNumber_INT01, <Yes>, <No>, <Yes>, <Yes>, <No>). The users exit the quantity field sometimes by tabbing out of it, sometimes by clicking where the item number field is in the next blank row.

In IE this has worked well for a very long time. The focus ends up on the editable item number field of the last row to be inserted and we can go to the next row and keep entering data.

In Chrome and Edge the editable field in the next row that you click in be blank/empty (unlike in IE) after the rest of the rows/columns are populated and the focus ends up in the editable item number field, just like in IE.

I've tried a few things to try to disable or move selection without success. I'm not sure if I'm the only one seeing this or if I'm just doing a poor job of describing the issue to find anyone else talking about it.

Has anyone else seen something like this? Any suggestions?

JDE 9.2 EnterpriseOne Tools Release: 9.2.4.5

Thanks!
 

JIANG

Member
Yes this happened to us as well. IE and Firefox work but Chrome and Edge not. To us, the issue is the cursor stops on the 1st editable grid cell and blanks out the value. We ended up creating a push button, and moving the 'insert grid buffer row' related code from grid-> Set Focus on Grid to the push button.

We are on E1 9.2.2.5.

Thanks, Jennifer
 

jlanawalt

Member
To keep the appearance of the existing workflow, one of the other developers worked around the issue by adding and hiding a fake line to the grid before all of our real lines are added in the event. He had tried deleting the fake/extra row near the end of the event but found that fails using Edge. On OK he removes the deletes blanked out "fake" lines so it seems like they never existed.
 
Top