TRIGGER HELP

gtfu

Member
Folks, trigger problem. Trying to do a voucher match on a PO. There are two lines in the voucher match screen. One is a legitamate line item and the other is an addition to the PO which is an account number. When i press enter, it should update the first line and the other will be an insert - good so far. However when i do this, i get a trigger error. I actually updates the first record fine and inserts the second but then the trigger is issued and it bombs. I can't even debug the trigger program (X4311) since it is a trigger. This worked fine 3 weeks ago, but since we did an os upgrade (v4r5 --> v5r1) this past weekend, we get this now. Any known issues with triggers? Thoughts? I was thinking of removing the triggers and then re-applying them.

Thanks for any assistance.
 

lpryor

Active Member
From the Knowledge Garden:
Issue 3:


An issue was discovered with some database trigger programs after an
upgrade to V5R1.  These triggers would potentially fail when an update,
insert, or delete to the file they were attached to occurred.  The reason
for the failure is that the offset for the incoming data containing the
original record and the new record were incorrectly defined within the
trigger.  The offset definitions were hard-coded rather than using the
incoming variables to position the reference of the original record and the
new record.


Resolution:


We have corrected the trigger programs to correctly position the location
of the original record and of the new record by using the incoming variable
offsets.
If you have installed A73PC000X3, download Software Update # 5383047.
To download this Software Update, click the Home icon in the Knowledge
Garden tool bar, then open the Product index bar, then click Software
Updates.  Enter 5383047 in the Software Update Number box.  You will
need your Knowledge Garden administrative logon and password.  Follow
the instructions included in the ReadMe file of this update.


You may apply the members from the download to your object library
before or after upgrading your AS/400 to V5R1.
If you have installed A73PC000X2,  a Software Update should be
available soon.
Additional consideration:


If you have custom trigger programs which fail as described above after
upgrading to V5R1, review the source code delivered in PCSRC within the
download library to see how JDE programs were changed.



gtfu
<gtfu@yahoo.com> To: jdeworldml@jdelist.com
Sent by: cc:
owner-jdeworldml@j Subject: TRIGGER HELP
delist.com


07/12/2001 03:46
PM
Please respond to
jdeworld






Folks, trigger problem. Trying to do a voucher match on a PO. There are two
lines in the voucher match screen. One is a legitamate line item and the
other is an addition to the PO which is an account number. When i press
enter, it should update the first line and the other will be an insert -
good so far. However when i do this, i get a trigger error. I actually
updates the first record fine and inserts the second but then the trigger
is issued and it bombs. I can't even debug the trigger program (X4311)
since it is a trigger. This worked fine 3 weeks ago, but since we did an os
upgrade (v4r5 --> v5r1) this past weekend, we get this now. Any known
issues with triggers? Thoughts? I was thinking of removing the triggers and
then re-applying them.

Thanks for any assistance.


--------------------------
Visit the forum to view this thread at:
http://198.144.193.139/cgi-bin/wwwthreads/showflat.pl?Cat
=&Board=W&Number=16140
 
Top