• Introducing Dark Mode! Switch by clicking on the lightbulb icon next to Search or by clicking on Default style at the bottom left of the page!

Table I/O insert being skipped

MarshallB

Well Known Member
Hi All,
I have a scenario where I'm trying to log some events/data from the P42101. I created a small custom table, and within the ER of the submit order button and another, custom button, I have several Table I/O inserts into my custom table. However, only one or two of the inserts are happening. It appears the execution is happening faster than the IO process can handle. If I run the code in ER debugger it works fine, but left alone several of the inserts are skipped. If I disable the first of the insert statements, the next one below it will run. I can disable/enable the insert statements like this, and make each of them run, but if they're all enabled it doesn't work. I tried explicitly opening/closing at each insert, tried checking for SV_fileIO success etc, but to no avail.

So far all testing has only been local on a dev machine, so maybe the behavior would change if run on the server?

I appreciate any suggestions for making this work.

JDE 9.2
Tools 9.2.1.4
Windows
Sql 2014
 

MarshallB

Well Known Member
Good catch, it did originally until i figured out no time had elapsed. So now my key is doco, date, and time + one. So i get the time once, on the first statement, then in each subsequent call I take my time variable +1.

As to where this is being called. First call is on the submit order (hidden) button click. We use a 3rd party credit card application, some of its functionality is on a custom button which is called from Submit order. So within 4 different if statements within the credit card button I call the insert again.

Brief backstory, we just upgraded to 9.2 (2nd week live), we've been using P42101, and this CC app for years in 9.1. Since the upgrade to 9.2 we occassionally (maybe 2% of the time) have an issue where we're not prompted to collect CC information even though the appropriate payment instrument is saved on the SO header. I'm trying to use my custom logging table to capture some data from each 'if' to see where its dropping out.
 

MarshallB

Well Known Member
Saying it out loud (typing it out loud?) was the key! My statement above was not entirely true, I had added the time + 1 variable, but I had not removed the fetch for time, so I was still causing the duplicate key error. Cleaned it up and it now works.

Thanks for the suggestions.

Marshall
 
Top