• JDELIST is celebrating its 20 year anniversary today!
  • Introducing Dark Mode! Switch by clicking on the lightbulb icon next to Search or by clicking on Default style at the bottom left of the page!

Table F98826 not populating on package build

KENNEY

Well Known Member
I am currently having an issue with building and deploying packages to our application server. I am building server only packages with reports on my full client work station. The build completes successfully, but when I attempt to deploy it to the server I get a message stating "The current package has been previously successfully deployed". When I look at my logs it shows that it is attempting to read F98826 (Package deployments on servers) (with a deploy status of 20) and not finding the record for the package in question which none exists at any status. Viewing the logs from the package build I don't see any attempt to create this record. I manually added the record to the table and the deployment worked.

Any ideas,

PS its been about 6 months since I last created an update package and it worked fine then.
 

altquark

Legendary Poster
You might want to consider building and deploying a full package. Seems that the package tables have gotten messed up somewhere along the way - perhaps you deployed a tools release or something similar ?
 

peterbruce

Legendary Poster
Michael,

Six months is a while to try to remember what is needed. It sounds like you forgot to create the deployment record after the package build. There is a deployment row exit from the package build application (P9621) that runs the deployment director (P9631) which adds the deployment record. Or you can run the Deployment Director (P9631) from the package and deployment tools menu and click ADD to create the deployment record.
 

KENNEY

Well Known Member
Solved

Thank you for the help .
Peter you were right. I needed to submit the deployment from the " work with package build definition" , I was trying to deploy it from the "Work with Package Deployment" (P9631). The deploy from the prior goes through a script process. I guess too many years of keeping this old girl going has made me a little rusty.
 
Top