• Introducing Dark Mode! Switch by clicking on the lightbulb icon next to Search or by clicking on Default style at the bottom left of the page!

Table Conversion (Foreign Table MS SQL 7.0)

Hi List,

JDEOW 7.333, Oracle 8.05

I want to ask a question about preparing a foreign table (SQL 7.0) data source for table conversion, maybe you worked with this.

I make:
1. a new environment
2. a new data source
3. add a default line for this environment in OCM and made it available
4. create table conversion.

I can open session in SQL server, but I can't receive list of foreign tables.

I think that my problem is in preparing data source.
Application "Database Data Sources" has a field "Object Owner ID" and checkbox "Use Table Owner".
What I do:
1. type "dbo" in "Database data sources" field
2. check "Use table owner" box.

Probably I do something wrong in settings or maybe something else.

WBR,
Vladimir
 

pcaenaro

Well Known Member
Hi Vladimir,

What seems to be missing in your process is the ODBC datasource... (outside
of One World)
That is the ODBC data source that you use when you define your OW Data
Source
I did that following the One World Developer's Guide and it worked fine (I
am using access though)

As for the Object Owner field, I left it blank
And I didn't check the "Use table owner"

Hope this helps

Regards

Philippe
----- Original Message -----
From: "VladimirKlimenko" <VladimirKlimenko@RobertsonBlums.com.ua>
To: <jdeowdevml@jdelist.com>
Sent: Friday, February 09, 2001 6:34 AM
Subject: Table Conversion (Foreign Table MS SQL 7.0) ~~0:5328


> Hi List,
>
> JDEOW 7.333, Oracle 8.05
>
> I want to ask a question about preparing a foreign table (SQL 7.0) data
source for table conversion, maybe you worked with this.
>
> I make:
> 1. a new environment
> 2. a new data source
> 3. add a default line for this environment in OCM and made it available
> 4. create table conversion.
>
> I can open session in SQL server, but I can't receive list of foreign
tables.
>
> I think that my problem is in preparing data source.
> Application "Database Data Sources" has a field "Object Owner ID" and
checkbox "Use Table Owner".
> What I do:
> 1. type "dbo" in "Database data sources" field
> 2. check "Use table owner" box.
>
> Probably I do something wrong in settings or maybe something else.
>
> WBR,
> Vladimir
>
>
>
> --------------------------
> Visit the forum to view this thread at:
>
http://198.144.193.139/cgi-bin/wwwthreads/showflat.pl?Cat=&Board=OWDEV&Numbe
r=5328
> *************************************************************
> This is the JDEList One World / XE Developers Mailing List.
> Archives and information on how to SUBSCRIBE, and
> UNSUBSCRIBE can be found at http://www.JDELIST.com
> *************************************************************



One World B733 Oracle 8.1 RS6000
 

tnaik

Member
Hi Vlad,

The steps you have given for accessing foreign table looks good.
I guess you should check if your ODBC driver in windows for SQL Server. Make sure that you "Test the data source" while setting it up, because sometimes you need to enter user id and password for accessing the SQL table. If your Test fails thru windows it's not going to work in oneworld.

You don't need to enter "dbo" or check the "use table owner" check box. OCM data source should be checked. The Database name should be ur ODBC name. Finally in OCM you need to change the object status to "AV"

Hope this helps.

Tushar
 

tnaik

Member
Hi Vlad,

The steps you have given for accessing foreign table looks good.
I guess you should check if your ODBC driver in windows for SQL Server. Make sure that you "Test the data source" while setting it up, because sometimes you need to enter user id and password for accessing the SQL table. If your Test fails thru windows it's not going to work in oneworld.

You don't need to enter "dbo" or check the "use table owner" check box. OCM data source should be checked. The Database name should be ur ODBC name. Finally in OCM you need to change the object status to "AV"

Hope this helps.
 
Top