• Introducing Dark Mode! Switch by clicking on the lightbulb icon next to Search or by clicking on Default style at the bottom left of the page!

Table Conversion failure

We have table convertor to convert data from a file (native DB2/400) to a OneWorld generated table (FIBS01).
We always ran this convertor locally, which worked like a
charm.
It is our intention to run the convertor on our AS400 using
the OW Scheduler. So we created a server package and deployed FIBS01
and the table convertor to the AS400.
When we ran the TC on the AS400, the TC failed. Error messages were:

OS40001078 - DoPrepare: sql code is -204
JDB9900168 - Failed to initialize db request
JDB9909007 - Unable to obtain driver request handle

we did another test: we switched 'Buffered Inserts to Output
Tables' and 'Force Row by Row processing' of in the TC design,
deployed the TC again and now it worked. Accept:

- there were only 5400 records converted iso of 6700
- all the numeric fields were rounded, fe: .566777 became 1.000000
- some fields were blanc, while the corresponding fields in FIB32 were
populated (just Alphanumeric fields).

We ran the TC again locally (in CRP) and this worked fine. So the
problem is AS400 related.

Help on this would be much appreciated
Thanks!
 

Christian Audet

Moderator
Staff member
Hi !

We are doing similar work here between World and OneWorld and we got a issue similar to yours, in our case it was the ODBC on the OneWorld Server, there was a difference in the setup in the ODBC on the server and the One on the client.

If it it working fine localy then double check your Server ODBC link and the client access on the server. Make sure that the version of the client access is also the same on the client and on the server.

Christian Audet

Implementing B7333 (Xe) SP14.1, SQL
(Support B732, B7331 and B7332)
 
Thank you for your help Christian.
I have one small question: is your oneworld server a SQL Server machine? Are you on B7332 or Xe?
We use an as400 as an enterprise server and Client Access levels are the same. How does the setup of the ODBC drivers affect UBE's running on an AS400?
Thanx!!
 
Top