Standalone 9.2 OMW crashing on entry


Hi all, I hate to admit it, but I need some help on Standalone 9.2.

Has any had the issue where, when you go into Object Management Workbench from a freshly installed Standalone 9.2, you get an ‘ActivConsole.exe has stopped working’ message, and then JD Edwards just crashes?

Object Management Workbench is pretty fundamental, because that’s the main reason for installing Standalone from my perspective.

This standalone install and issue seems to have been consuming my life for the past couple of weeks, so I will give you the background of what I have done with the install, what I have tried to resolve the issue, and possible other resolutions that I can think of.


• Downloaded all of the correct 32-bit and 64-bit pre-requisite software, according to the Certifications for the 9.2 Development Client
• Downloaded the latest Standalone from e-delivery (Apps 9.2, Tools
• Installed Oracle VirtualBox, and loaded a fresh MSDN copy of Win7 Professional 64-bit and VS2013 (full)
• Turned off AV, Firewall, Windows Defender
• Ran everything in Administrator mode, where applicable
• Followed the installation instructions end-to-end from the E61424-04 Standalone Client Installation Guide, last updated November 2016
o Found the ‘12.3 Microsoft Windows IPv4 Requirement’ section very frustrating, that they tell you this AFTER the install that has already taken you days to complete
o Hope this is not my problem, and the log.xml file is inconclusive, as it has both IPv4 and IPv6 references in it
• Followed the ReconfigureDB.exe instructions to decrypt and re-encrypt the sys and sysadmin passwords, so that I could create myself a Super SysAd user on the Oracle database
• Installed Oracle SQLDeveloper, JD Edwards Object Browser, and OneWorld DebugLog Commander on top
• Oracle SQLDeveloper can access the database OK
• Standalone starts up OK, and you can go into applications
• WebClient starts up OK and I have changed records in P0006 successfully
• OMW crashes the JD Edwards client as soon as you try to go into it from FastPath, menu, or Batch Versions

Troubleshooting so far:

• I fixed all of the P98MOQUE entries, as advised and as per normal
• I adjusted the second tab of P98220 Processing Options, so that the first two fields point to an actual MOQUE and an actual file
o I seem to remember that this resolved very slow OMW start up issues on our ‘real’ JD Edwards installations
• I have tried FastPath, menu, and Batch Version access – all the same issue
• I tried level-6 jdedebug.log and jde.log – no reported issues, just stops mid-way through the load process, so looks like Tools failure as no errors are caught
• I tried ER Debugger on P98220 – W98220A, Dialog is Initialized and Post-Dialog is Initialized first events, but it doesn’t even get that far before crashing
• Opened up P98220 in FDA via JDE Object Browser, and ER Validation is OK
o Mad a dummy change, saved it, retested – same issue
• I tried downgrading the Tools release to (from the delivered – same issue
• I tried upgrading the Tools release to (from the delivered, with the recent fix to the .dll and .bsc files – same issue
• I tried building all BSFNs possible in Optimize mode, by calling BUSBUILD from the file structure after logging into JD Edwards – same issue
o CFIN, CINSTALL, and JDBTRIG1 thru 4 are all locked, so cannot be rebuilt
• Various internet and My Oracle Support searches

So, as you can see, I have given it a good go.

Possible other things that I am thinking about, none of which are overly attractive:

• The IPv4 versus IPv6 issue, but I don’t particularly want to do that, because it means *undoing virtually everything that I have done so far / starting from scratch with a new VM*, and without a guaranteed fix to the issue
• Doc ID 2135274.1 which describes the issue perfectly, but the solution is to build a package with the "Compress Data" and "Compress Foundation" options enabled during package definition
1. You can’t build packages on a Standalone
2. What does this actually change? (it says “update the .CAB files in the systemcomp and DATACOMP directories”, but these folders don’t exist on Standalone)
3. Does someone have copies of the files that this affects, so that I can just try to replace them on my Standalone?
• Logging a call with Oracle

Hopefully someone else has had this issue, because we have all been installing the same software, it’s just I can’t seem to find anyone reporting the issue on the internet.

Any suggestions?

Thanks for your help in advance, guys,

Hi Russ

I've not experienced the exact problem you describe, however I've seen something similar - my standalone E920 will crash when changing the UserRole on an owner of an OMW project (I now have to add the same owner to the project again with a different role to get around this).

I suspect that your problem may be related to the owners or owner's roles of the default OMW projects. Have you had a look at P98230 to make sure everything looks as it should for User Roles, allowed action, activity rules etc?

Hope this helps
Thanks Aidy, good idea, because if it is failing before it gets to dialog is initialized, it must be something that the Tools is invoking, like security.

I found some odd things, so I changed those:

F98221 - updated rows to 'DEMO' where PUOMWUSER <> 'DEMO'
F98222 - updated rows to 'DEMO' where POOMWUSER <> 'DEMO'
F98224 - deleted rows where SROMWUSER = 'TW5501429'
F98225 - deleted rows where TROMWUSER = 'TW5501429'
P98230 - disabled object action notification
P98230 - Allowed Actions - '38' was missing in H92/PS, so I added that back in

Retested, but still failed.

So I thought, why not take all of the OMW projects out, in case one of them is causing a problem:

F96413 - deleted all rows
F98210 - deleted all rows
F98220 - deleted all rows
F98221 - deleted all rows
F98222 - deleted all rows

Retested, but still failed.

I checked P00950, P0092, P95921, P98OWSEC, but they all looked good to me.

Back to the drawing board ...
Thanks Rauf. I have attached a zip file with all of the logs gathered.

At various pause points in the process, I put comments in the logs like these:

Just about to type OMW in the fast path, and then press enter, followed by the crash
System has now crashed, "activeConsole.exe has stopped working" message displayed
Close Program button was pressed on dialog box, JDE shut down, but java and jdenet still running

After the last one, I killed the processes that were still open, and no further entries were added to the logs.

In the EventViewer it gives me much the same info:
c:\e920_1\system\bin32\activConsole.exe is the faulting application
c:\windows\syswow64\kernelbase.dll is the faulting module

And then in the WER ReportArchive, it give a list of the dlls that were loaded at the time of the crash.

Nothing else in EventViewer seems relevant (I looked at ALL the logs...)


    479.4 KB · Views: 15
You could try and use the event rule debugger and see if any code is actually being executed. Also you mentioned you tried to run OMW from Batch Versions. I assume you meant Interactive Versions?

Hi Neal,

Thanks, yes I did try ER Debugger in the initial round of trying to get it to work, but even with a debug point set on the first event rule of the Dialog is Initialized event, it didn't even get to that point, so the problem lies before that, presumably in something that the Tools are doing.

BV and IV - yes, correct, schoolboy typing error ! (I use BV all the time, so it just rolled off of the fingers...)

Another couple of things you could try. Check the processing option values of the OMW version you are trying to run and see if there are any dodgy looking values. Also try creating a brand new version and run that from Interactive Versions. Good luck!
Hi Russ

Check this out:

E1: RDA: Open Report Design Aid, Blank Screen in Design, No Sections are displayed (Doc ID 634824.1)

Hope this helps

Aidy ....

You absolute beauty !!

It worked. :)

I don't know which ocx or dll it was, but I registered them as per the MOS document instructions, and I also used a 3rd party tool that you can view the registrations for, too (regdllview from It showed that all of the dlls and ocx entries that were listed in the MOS document, were strangely already registered.

I registered them through the regsrv32 method and although reported successful, the entries in regdllview did not seem to change in any way. An F8 option against each of the registered files in regdllview will also re-register the files, but when I did this on design.ocx (and maybe others), there seemed to be a whole lot more ClassIDs registered than there were before .. .so I did F8 on all of them to re-register.

E1Soap didn't seem to re-register through that utility, for some reason, so I made sure that regsvr32 reported it successful. After that, I rebooted, went into JDE, typed OMW, and voila !!

Thanks so much for finding that. We had narrowed it down to any form with a Media Object being displayed on it would fail, just around the time it was fetching info from the F00166 table, but that is as far as we had got.

As suspected, something in the Tools that was invisible to ERdebugger, but it must have been a failure in the installation process that was not reported (or was reported in one of a hundred logs with thousands of lines in them!).

Thanks again, for yours and everyone's help, and hopefully I will be able to use OMW as intended now .. if not, I will just re-register everything in system/bin32 !

Hi Russ

Glad it worked. It was probably the registering of the System\bin32\jdectocx.ocx file that solved the OMW issue.

Last edited:
Hi All. I Have followed the instructions very closely and I'm now at a dead end. The log indicates I have the ORA-12528: TNS:listener: all appropriate instances are blocking new connection error.

Following advice I have updated tnsnames with various suggestions and connected to the database manually by encrypting / decrypting passwords ReconfigureDB.exe and so forth and the database and listeners are active.. However I still have a connection issue. The log indicates it is trying connecting to a 64 bit database but the install was for 32 bit database. So security server is not found.

8644/8636 MAIN_THREAD Thu Mar 23 16:06:28.036001 jdecsec.c2706
Failed to communicate with security server: Unable to locate Security Server

Mar 23 16:00:46.862002 - 8496/8272 UNKNOWN Database driver name is 'jdboci121.DLL'
Mar 23 16:00:47.065000 - 8496/8272 UNKNOWN Exited CreateCriticalSections_oracle with ref cnt 1
Mar 23 16:00:47.112000 - 8496/8272 UNKNOWN ORACLE DBInitDrv envr=03544768
Mar 23 16:00:47.112001 - 8496/8272 UNKNOWN ExaData is set to <1>
Mar 23 16:00:47.628000 - 8496/8272 UNKNOWN ORACLE DBInitCon - Database server version is 'Oracle Database 12c Enterprise Edition Release - 64bit Production'
Mar 23 16:00:47.628001 - 8496/8272 UNKNOWN ORACLE DBInitCon envr=03544768 conn=0858DC50 localhost A (SYSTEM@E1Local) V121 Unicode=Y (srvrusers=1) 1
Mar 23 16:00:48.081000 - 8496/8272 UNKNOWN Exiting JDB_OpenTable(Table = F986101) (UserHandle 0851EEC0) (hRequest 0353CD28) with Success
Mar 23 16:00:48.097000 - 8496/8272 UNKNOWN Entering JDB_SetSelectionX (hRequest 0353CD28)
Mar 23 16:00:48.097001 - 8496/8272 UNKNOWN Exiting JDB_SetSelectionX With Success
Mar 23 16:00:48.097002 - 8496/8272 UNKNOWN Entering JDB_SelectKeyed (hRequest 0353CD28)
Mar 23 16:00:48.112000 - 8496/8272 UNKNOWN ORACLE DBInitReq conn=0858DC50 requ=08602188 localhost (E1Local) new [ 1]
Mar 23 16:00:48.159000 - 8496/8272 UNKNOWN MaxFetchNumRows is set to <100>
Mar 23 16:00:48.159001 - 8496/8272 UNKNOWN MaxFetchNumBytes is set to <64000>
Mar 23 16:00:48.269002 - 8496/8272 UNKNOWN OCI0000179 - Error - ORA-00942: table or view does not exist
Mar 23 16:00:48.315000 - 8496/8272 UNKNOWN JDB9900170 - Failed to execute db request

Any other tips out there?

Many Thanks