SP24.0.2 and Websphere 6.1 generation issues



Active Member
Hi all

We are trying to upgrade to Websphere 6.1, AIX 5.3 SP24.02 and I have struck some issues with the web generator.

When I run the web generator and build core objects and then an app such as P01012 it all appears to work fine, but when I log into the JAS session, I get a message "could not load form".

The web server is running on AIX and is a bit of a complicated setup in that it is running WAS 5.0 and WAS 6.1. I installled JDK 1.5 as part of the WAS6.1 install but I can also see that Java 1.3.1 also is installed, so I dont know if that is causing issues.

I have a call open with Oracle but I dont seem to be getting far.

The instructions in the JAS manual for setting up the generator seem to be more for 8.96+ than SP23/Sp24. I'm not sure if the gen.bat is correct or something else on the client is wrong or missing.

Other things I have tried are truncating the Serialised objects tables, checking service pack levels of the web server and webgen machine and copying the j2ee.jar from the web server.

Has anyone managed to get this work and could you post your gen.bat and any issues you found?

AIX5.3, Sp24.0.2, WAS
I have the identical setup (WS6.1 on AIX5.3 with SP24.0.2) working just fine -- have you tried just going ahead with a full generation and then seeing if it works? Do you have a test environment where you could truncate the F98999* tables and do a completely fresh generation?

We found the issue last night. We reinstalled the Sp24.0.2 on the dep server, built a new foundation package and deployed it, and reconfigured the generator and it worked! The configuration was the same as before so we are wondering if the packages were wrong or the Sp24 didnt install correctly on the dep server the first time.

We also found that the generator is a saying Sp22 in the Help>About screen so we have asked Oracle why this is.