E9.2 Some users cannot see their favorites



We have this odd issue where some of our users are not seeing their favorites.

When they right-click a task from their main menu, they can add a favorite: the pop-up window comes up to rename the task but nothing happens after clicking "Create Favorite".
Nothing comes up when they click the "Manage Favorites" button.
I went to P01RS01 and I can see that these users have added tasks to their favorite folder. They just don't see them.
I checked the security settings and the favorite option is activated at the *PUBLIC level and it is not secured at other levels.
Finally, I tried both user types (with and without favorites working) on my workstation, to eliminate any browser/OS compatibility issues.

In conclusion, I think this is user related but can't find the culprit setup.
Any help would be greatly appreciated.
Thanks in advance,


We found a setup in P9000 - Work With Task Views.
We went to the Task View Revisions for the Favorites and there was a check box "Secured Task View" that we unchecked.
Then all users seemed to have access to their favorites.
But it still doesn't explain why some could see it and others couldn't before we did this...