Single Threaded UBEs

Kari_1

Member
Hello List,

I am having trouble with certain UBEs (the R42800 and the R42656 amongst others)which when run on the server process correctly and go to a 'DONE' status. However they are actually still running on the server preventing any further UBEs from processing. The UBEs submitted after this happens sit in a "In Queue" status in the Submitted Jobs screen.

Although we are able to kill the process once its finished through Unix and allow the others to process this is obviously not a long term solution.

I have looked on the knowledge garden and JDE recommend setting up multiple thread batch queues and single thread batch queues to resolve this issue. However, even when I ran these UBEs on one of our single thread queues the same thing happened.

Has anyone had any experience of this and have any advice to resolve it?

thankyou

Kari

OneWorld B7332 SP11
Oracle 8.1.6
HP-Unix b.11.0
 
This is a multi-part message in MIME format.

------_=_NextPart_001_01C08C8F.E1E53200
Content-Transfer-Encoding: quoted-printable
Content-Type: text/plain;
charset="iso-8859-1"

We are having problems with this as well. What causes this?
 

Larry_Jones

Legendary Poster
Hmmm, although we have similiar environments this is not a problem that we experience ...

perhaps your server spec files are corrupted? What happens when you run these UBE in a different environment (CRP or PRISTINE)?

Larry Jones
ljones@wagstaff.com
OneWorld B733.1, SP 11.3
HPUX 11, Oracle SE 8.1.6
 

christian_h

Member
Re: RE: Single Threaded UBEs

We too are having problems with this on the same release, OS and DB as kari_1. We are seeing that the the runbatch puts the job into a "D" done status but not terminating. I would guess that it is doing some sort of clean-up before it completes and it is hanging while its waiting to release a resource (just a guess). But, we do see that it is consuming quite a lot of CPU still and so I would imagine there is some looping going on in the code in an infinite attempt to retry something. Nothing is coming out in any logs.

Does any one know what the runbatch program does after it updates "submitted jobs" table to put the job into a "D" status?

Thanks,
Chris
 

Larry_Jones

Legendary Poster
Re: RE: Single Threaded UBEs

Here's a thought, try checking the permissions of the ./log and ./printqueue directories to ensure that the UBE process user (jde, jdeb7331?) have write privileges to the directory. I know its way out there, but perhaps this is the issue if you are not seeing any logs generated.



Larry Jones
ljones@wagstaff.com
OneWorld B733.1, SP 11.3
HPUX 11, Oracle SE 8.1.6
SandBox: OneWorld XE
 
Top