• Introducing Dark Mode! Switch by clicking on the lightbulb icon next to Search or by clicking on Default style at the bottom left of the page!

Serialized Tables empty and no visible Web Menus

Bulldog

Active Member
HI, I have the following issue; Successfully built and deployed a 8.11 full PY package, (backed up the JAS/System folder and restored after package installed) and Installed the package onto a generation machine and then generated DD's and Global Tables, performed the full web generation (JPY811) but when I log into PY web client there are no menus whatsoever, just a blank page. When I look at the PY811.F989998 and PY811.F989999 tables they are empty (tables were truncated before the web generation). I have tried the same procedure on another generation machine but the results are the same. Could the issue be related to the JAS.INI, JDBJ.INI? Any help would be much appreciated, it's probably something simple but I can't see the woods for the trees.

regards...
 

altquark

Legendary Poster
There must be some JDE.LOG on your generator machine that is indicating the failure to connect to the Serialized Objects tables.

Obviously you're on 8.11 (no need to do "generation" since 8.12) - but what Tools Release ? What platform ?
 

Bulldog

Active Member
Hi Jon, thanks for replying - the details are as follows: Release 8.11 and Tools Release 8.95 - Database SQL2000/Windows Server 2003 Enterprise Edition SP1
 

cody_bell

Active Member
What are you using for your JAS & HTTP solution?
Do you have auto-gen enabled in the ini file?

I have seen menus not showing up before but my issue was at the JAS/HTTP level, not the Web-Gen level.
I'm using JAS thru WebSphere and Apache HTTP in an all-in-one iSeries machine.

This was my solution ...

The files needed to access and create the menus did not have the correct security. I had to change security on files in the HTTP configuration and the WebSphere directory structure.

Do you have menus in other environments?
 

ice_cube210

VIP Member
check the JAS.INI and JDBJ.ini on the generator machine. Check if JDBJ spec datasource is hardcoded to the local spec DB instead of being commented out , which would make it use OCM.

Also confirm that gen.bat is pointing to all the correct folders
 

Bulldog

Active Member
Thanks Guys - Using Websphere but I think the issue lies with what ice_Cube was saying - check the JAS.ini and JDBJ.ini on the generation machine - I have tried on two seperate gen machines with the same result - serialized tables empty. It could be [spec datasource] hardcoded to local DB or incorrect OCM mappings. Not had a chance to get back into system as yet to check on these things - thanks for your helpful advice, will let you know what the outcome was so its posted on the site and helps other people, regards...
 
Top