R47032 missing some ASN lines but moving on to 620 (overlap issue?)

johndanter

Legendary Poster
Hi guys,

We've noticed a weird issue here in that every now and again our scheduled job of R47032 will sometimes appear to miss F4211 records in the ASN but looking the F4211 we can see that R47032 HAS moved them onto 620

Our job runs at 7min and 37min passed the hour

Now the config is all fine, as if we re run it from F42199 it works fine, so it's not that. The customers/item/pallet setup etc is all good to go.

What I think is happening is the records that are missing went to 575 AFTER 7 min passed - but that's ok as the 37 min job should have picked them up - Except it's not (as they got moves to 620 by the 7 min job)

I think when the 7min runs it select records at 575 and moves them to 620, but I think if the job is taking too long (which it did in our case) the 1st job seems to have an update statement in there somewhere that will update ANYTHING at 575 and nudge them to 620

So it seems if any SO lines move to 575 during the run cycle of R47032 then the UBE will move them on to 620 But then may not actually place them in the ASN

Anyone else experienced this?

R4981 moves them to 575
R47032 picks them up @ 575 and moves them to 620 and puts them in the ASN


Is it right to schedule to the R47032 or should we be envoking ther R4981 and R47032 link in a different way? Possibly in a single threaded queue one after the other...?

Thanks

John
 
Last edited:

johndanter

Legendary Poster
Can anyone please give me an insight into how your business generates the ASNs?
Is the R47032 scheduled or is it called by a process in steps?

Thanks

John
 
Top