R42565 UBE errors when runningon the Server

All,

We have copied the R42565 Print Invoice UBE and added some code changes.
The changes only add functionality to the UBE and do not alter the "core"
code.

The UBE runs fine locally.

It does NOT run on the server.

Here is what we have tried to fix the problem:

1) Generated a header file (for the Report interconnects) and built/deployed
a full server pack. The UBE still returns an "E" status when run on the
server.

2) Eliminated the report interconnect data structure and all code associated
with the report interconnect data structure. The UBE still returns an "E"
status when run on the server.

3) Enabled the "Submit Version Specifications Only" checkbox on the Advanced
Tab, when submitting the job to the server. The UBE returns an "D" status
when run on the server but no PDF can be recovered from the server.

We have run out of ideas. We would be greatful for any ideas that yall can
provide.

I am eagerly awaiting your responses,

Bernie

B733 SP7.1_OEXP
 

got_to_love_jde

Reputable Poster
Bernie,
have you turned on logging and tracing when you submit the job to run on the server ? did the logs show anything interesting ?
did you happen to create any new business views that need to be deployed ?
dave


NT 4.0 SP5, SQL 7.0, One World B7321 SP12.4
 
Dave,

No new views where created. The new codes does some table I/O and text
manipulation, but nothing special or unusual. The logging returned the
following several times in the JDE.log:

1739 Thu Nov 30 12:50:15 2000 winansi1294
LIB0000071 - GetProcAddress: Can't find procedure
LoadAndRetrieveQuantumTaxCache

1739 Thu Nov 30 12:50:15 2000 jdeobj964
COB0000012 - GetProcAddress failed libCALLBSFN.sl function
LoadAndRetrieveQuantumTaxCache Error = 0

1739 Thu Nov 30 12:50:15 2000 winansi1294
LIB0000071 - GetProcAddress: Can't find procedure
LoadAndRetrieveQuantumTaxCache

1739 Thu Nov 30 12:50:15 2000 jdeobj964
COB0000012 - GetProcAddress failed libCALLBSFN.sl function
LoadAndRetrieveQuantumTaxCache Error = 0

1739 Thu Nov 30 12:50:15 2000 winansi1294
LIB0000071 - GetProcAddress: Can't find procedure
CalculateValidateTaxAmounts

Any ideas?

Bernie

B733 SP7.1_OEXP (Oracle/UNIX)
 
We have been having similar problems with R42565 (Invoice Print). We copied
an XJDE version and made changes to it and it will not run correctly on the
server (AS/400). What we have done as a workaround is to run the XJDE
version nightly on the server only to advance the status. Then we run our
version locally the next day for printing purposes. We cannot figure out why
our version will not run correctly on the server. Ours does not error out,
but will only print 5 invoices and then end. What is even stranger is that
our version used to run on the server and quit suddenly for no apparent
reason. When you copy a JDE version and modify it, what could change that
would make it no longer run on the server? We also have the same problem for
acknowledgements which also utilizes R42565. It would be super if someone
could solve this issue.

Thank you,

Tom Chmielewski
Flair Corp.
Ocala, Fl
B733.2 SP11.3 AS/400, NT, CITRIX WTS




Tom Chmielewski
Sr. Programmer/Analyst
Flair Corp.
Ocala, Fl
 
Top