R09801 shows "No F0911 records exist in this Batch.

Rauf

VIP Member
The PDF of job R09801 shows "No F0911 records exist in this Batch" after posting a payment. Where should I check this issue.

As far as I know, F0911 records for a paymet is generated while posting.

This issue is for some payments done on two months ago. And for current batches, no issues.

How should I fix those batches ?
 

Rauf

VIP Member
I have got some hints from Oracle documents. But I have restricted access to My Oracle Support.

Attached please find the error from View Job Status

The documents says as below. Any body have some thing to tell :confused: ?

E1: 04: Payment Batch Error: No F0911 Records Exist in This Batch
(Doc ID 2250475.1)

Last updated on MARCH 31, 2017
Applies to:
JD Edwards EnterpriseOne Accounts Payable - Version 9.1 and later
Information in this document applies to any platform.
Symptoms
A payment batch may fail due to an AP PrePayment BSFN function (B000062) comparing the corresponding paid voucher (F0411) table data and payment voucher (F0414) table data by the follow fields: DOC, DCT, KCO, SFX and SFXE. If there is a failure to match any one of the fields the following error (error number 0002) will occur on the R09801E error report: 'No F0911 Records exist in this Batch'. In addition, the work center message displays a message 'Payment 0 0 in Error'
*
Change the error messaging to provide a better error description to help the user to determine and quickly correct the matching process so that the payment batch can post.
 

Attachments

  • 2018-04-02 15_31_42-R09801_ZJDE0004_3609073_PDF[1].pdf - Adobe Acrobat Pro Extended.jpg
    2018-04-02 15_31_42-R09801_ZJDE0004_3609073_PDF[1].pdf - Adobe Acrobat Pro Extended.jpg
    8 KB · Views: 17
Last edited:

Rauf

VIP Member
Found the issue !!!!!

It was due to security setup over the company and another user tried to post the batches before.

So the following happened:

Issue:-
  • USER-A have no access to Co 01 on F0911 level.
  • USER-A selects a batch of Co 01 and post it.
  • During posting process, R09801 tries to insert records to F0911. But it fails due to restricted access.
  • The header of the payment (F0413) and batch header(F0011) sets to posted status, but the status is Payment Details (F0414) will remain as blank.
  • The output report will show 'No F0911 Records exist in this Batch'


Resolution:-
  • I have tried re-posting but it did not work, because the status in payment header is posted
  • So I set the status to blank, and re-posted. But still got the same issue.
  • Now, I set the posted status in both payment header and details as P.
  • Then, the batch is posted correctly.
 
Top