• Welcome to the upgraded JDELIST forum and thank you for your patience.
    Please restrict discussions and issues regarding the new forum software to the Off Topic forum. We will be monitoring that forum for issues.
    If you have trouble logging in, please reset your password using the forgotten password form: https://www.jdelist.com/community/index.php?lost-password/
    If you are unable to successfully reset your password, please contact us: Click here!
    We hope that you enjoy the upgraded forum.
  • Introducing Dark Mode! Switch by clicking on the lightbulb icon next to Search or by clicking on Default style at the bottom left of the page!

Problems Creating BIPublisher report with JDE E1.

Hello,

I am trying to use BIPublisher 10.1.3.4 enterprise by creating a jdbc connection to JDE E1. The jdbc connection is established successfully.

But when I try to create a SQL/Datamodel in the report, I am encountering different types of errors. The list of tables are listed when I click Query builder. But,

1. If I select any table there, it is giving "[SECURITY_ERROR] A Security error occured"

2. I wrote a SQL query as
"SELECT F0150.MAPA8
FROM JDE.F0150 F0150"

and when tried to execute the report I am getting this error:

"[SPEC_NOT_FOUND] Unable to find OneWorld specification for MAPA8.
"

3. Some times, It allows to create the query from the query builder but when tried to execute, throwing error
"Unable to parse operation"

4. When tried to execute a simple statement to retrieve all columns from the table, following error is occuring:

[BSFN_CALLOBJECT_ERROR] An error occurred during the call to trigger business function F0101_FETCHAFTER: COSE#1010 Remote environment initilization failed. Please see Enterprise Server log for details, env. maynot be supported by server: JDB_ERR: FAILED TO LOAD ENV.

The following simple queries works:

SELECT PA8, AN8
FROM JDE.F0150
WHERE AN8>100

SELECT *
FROM JDE.F0150
WHERE AN8>100

But the same is not happening with the below query:

SELECT AN8
FROM JDE.F0101

Please suggest if there is any change in the notation of the query or anything is missing from the above query. Also what are the specific care to be taken when writing a query involving more than 1 JDE tables.

If anybody have encountered similar errors, or know the solution for this, please advise us.

Thank you
Narasimha
 

Chan Rana

Member
Seems like its failing for bulk row query. Check the nos of rows limit or other setup related with your CNC.
Also check the logs files which can give you more details.

Thanks,
Chan
 
Hello Chan, thank you for your response.

that was just a sample query I have put in. I tried joining other tables and it should retrieve only 4 records. That query was running good and retrieving data from SQL developer.

We are investigating the custom table level triggers etc.. put in to implement security restrictions.

By the way, I have another question. Is there anyway we can restrict the number or rows retrieved by a query? like by using rownum<5 for example? If I use the rownum in the BIP query it is leading to error.

are there any restrictions in using rownum in BIP query on JDE tables?

thank you for your time.

Narasimha Rao
 
Top