PDF Viewer

ltm

Member
Dear List

Has anyone got any idea how to bypass the message below while executing an UBE report other than locating the viewer ourselves or using Acrobat 3 viewer.

"Unable to locate the pdf viewer (%s), would you like to locate yourself?"

This message only appears if versions higher than Acrobat 3 viewer is installed with Standalone Oneworld B7.3.3.1 e.g Acrobat 4.0 or Acrobat 5.0 viewers.

Knowledge Garden mentioned about correction but only in the future release.

Thanks

Regards
ltm
 

juan_botero

Member
I did the following, I left the acrobat reader version 3.0 installed and I
replace the acrobat 3.0 files inside the folders for the acrobat 4.0, amd
it worked.
 

jwalker

Active Member
We had this same problem when we were running OW B733 and Acrobat Reader 4.0
so I don't know if this fix will work for you or not, but it's worth a try.
Using regedit go to:

My Computer\HKEY_CLASSES_ROOT\AcroExch.Document\shell\open\command

And take out the extra double quotes that are around the path and before the
% sign. Also see attachment.

<<Acrobat Reader 4.0 problem.doc>>

-----------------------------------------
Justin Walker
Systems Administrator
Colorado Christian University
303-963-3398
mailto:[email protected]
-----------------------------------------
 

Guest

Guest
Try this.

[HKEY_CLASSES_ROOT\AcroExch.Document\shell\open\command]
@="C:\\Program Files\\Adobe\\Acrobat 4.0\\Reader\\AcroRd32.exe \"%1\""

Crawford
 

ltm

Member
Hi List

My conclusion and observation after trying out the suggestions from Juan, Justin and Crawford.

Here's how to avoid the OneWorld message:
1) Uninstall whatever versions of Acrobat Viewer.
2) Reinstall the Acrobat5.0 (if you want to use version 5.0) in the "c:\Acrobat3" folder instead of the default location. The reason for doing this is I believe OneWorld could have been hard-coded to work with Acrobat3.
3) Check the registry or file type definition that the extra double quotes that are around the path and before the % sign are removed. It should be: c:\Acrobat3\Reader\AcroRd32.exe "%1".

We should be able to use Acrobat5.0 to view any PDF files including UBEs from OneWorld with the said message.

Thanks again Juan, Justin and Crawford.

Regards
ltm
 

vap

Active Member
ltm,

You may be right. For your OW release level and SP, which you did not share with us.
As far as I remember I had this issue in B7331 (it did not work with Acrobat 4.0, if it was installed in default directory). The problem was that OW did not handle quotes in command string (see registry in earlier mail), and if you remove quotes, it can't handle space in the path. Solution was to install Actobat to a path without spaces, and then remove quotes. It was fixed in some SP for B7331, if i remember correctly 9. Or was it 10? It was more then two years ago. B7332 was working correctly from SP11, which was the base SP, if i remember correctly. XE was never effected.

Regards,
Vladimir Ponomarev
B733, B7331, B7332, XE (mostly XE at the moment); SQL 7.0, Oracle 8.1.5, DB/400 (mostly SQL); Wintel, HP, AS/400 (mostly Wintel)
PS: Put your system configuration in your signature, help us to help you.
 

ltm

Member
Dear Vap,

Your comments noted.

It's standalone OneWorld B73.3.1 version SP6.

Thanks & regards
ltm
Xe (base), B7332, B7331 mostly on NT (SQL).
 
Top