E9.2 P98ORCH / B98ORCH run locally on Web Dev Client

BOster

Legendary Poster
Can you run P98ORCH / B98ORCH locally on Web Dev Client? I can run on the JAS (JTS920) server but when I try and run locally (TS920) from my Web Dev Client (with same JDE credentials) I am getting this error back:

{"message":"AIS Login Failure","submitted":false}

Is this just a configuration thing?
 

Dave Azouth

Member
Hi Boster,

You need to set this information in the fat client jde.ini

[FORMSERVICE]
AISHost=<AIS_Server>
AISMaxConcurrentCalls=5
AISPort=<AIS_POrt>
AISProtocol=http

And of course have an AIS Server running.

Dave
 

BOster

Legendary Poster
Just a little more info (can we not edit original posts in this forum?).

This isn't making sense to me.

When I log in on a JAS server which is the JDV920 environment I can call an orchestration successfully using P98ORCH.

Using the same credentials, when I log in locally on a Web Dev Client to the DV920 environment and try and call the same Orchestration using P98ORCH I get the AIS Login Failure shown above.

Further more, (and this doesn't make any sense) if I log in to the JDV920 environment on my local Web Dev Client so that all BSFNs including B98ORCH are running on the Logic Server, i.e. the BSFNs are running the same place as when logged into JAS/JDV920 I still get the error.
 

tblancett

Member
Brian, did you add the FORMSERVICE information to the fatclient jas.ini as well? We had the same issue as you are describing until we made sure we had it specified in both the jde.ini and jas.ini for the affected fatclients.
 

BOster

Legendary Poster
Brian, did you add the FORMSERVICE information to the fatclient jas.ini as well? We had the same issue as you are describing until we made sure we had it specified in both the jde.ini and jas.ini for the affected fatclients.
Just a follow up. Got it working locally using the jde.ini settings shown above. Couple of additional notes. If you are using https instead of http as shown above (as we are) you may need to add the AIS server's certificate to \E920\System\bin32\cacert.pem as well as the trust store used by your local web dev JAS app server if you are using a self-signed cert. You can get away with just adding to \bin32\cacert.pem if you edit the file \E920\system\JAS\EA_JAS_80.ear\webclient.war\WEB-INF\classes\LocalLogicCatalog.xml and comment out the following entry like shown below:

Code:
<!--
    <business-logic
        module="B98ORCH"
        function="CallOrchestrationNotification"
        run-local="true"/>
-->

This will disable the Java implementation of CallOrchestrationNotification.

Note that if you do this hack CallOrchestrationNotification will always use the C implementation of the BSFN even when called from ER code in an APPL which will differ slightly from how it is ran on the actual JAS server which will call the in-lined Java implementation of CallOrchestrationNotification. But for Local Web Dev testing this is probably fine and negates the hassle of having to import certs into the app server trust store.
 
Top