E9.2 Orchestration works in P98ORCH but not in UBE via B98ORCH

ehignett

Member
I have a very simple orchestration that calls a form request for P42040 passing the order number, type, and line number to advance the order status. If I run it directly from P98ORCH using the input parameters, it does exactly what I want. I also have it in a UBE, passing the same input parameters to B98ORCH. If I run it this way, it doesn't advance the status but I don't get any errors - both methods return the identical Output String (JSON Response). Our CNC says it is not security related and has restarted the servers but nothing so far. Any thoughts?
 

BOster

Legendary Poster
Not sure why the status doesn't update if you are sure the orchestration is running. Note that when B98ORCH runs on the JAS server it runs as a Java implementation of the BSFN (it is listed in \webclient.war\WEB-INF\classes\LocalLogicCatalog.xml) so it never runs the C version of the BSFN on the ES server. However, if B98ORCH is called from another BSFN or a UBE the C version of the function will run on the ES.

To make sure the orchestration is actually being invoked from the ES server which would be the case when B98ORCH is run from a UBE:

1. Make sure the following is in the jde.ini file on the ES server
Code:
[FORMSERVICE]
AISHost=aisserver.xxx      <<< actual fully qualified host name of the ais server goes here
AISMaxConcurrentCalls=5
AISPort=8xxxx     <<<actual port number goes here
AISProtocol=https

2. If AISProtocol = https, make sure that the ES server has the AIS/Orchestration certificates in \system\bin32\cacert.pem.


BTW, you have to do all of this locally as well if that is where you are running into the issue. Locally I simply disable the entry in LocalLogicCatalog.xml so that the C BSFN version always runs, then all I have to do is make sure the AIS certs are in cacert.pem.
 
Top