oracle.e1.bssvfoundation.exception.BSFNServiceRunt imeException: Server Failure while

kishorgite

Member
I am getting below error while running simple BSSV in which i just called InvRealTimeItemAvailability BSFN .

oracle.e1.bssvfoundation.exception.BSFNServiceRuntimeException: Server Failure while executing business function. Please try request again. :InvRealTimeItemAvailability(Item Availability Real Time Query Results)

after debugging i am getting such kind of message which i did not understand .

Caused by: com.jdedwards.system.connector.dynamic.InvalidRemoteSessionException: Fail to execute BSFNMethod com.jdedwards.system.kernel.CallObjectSystemException: Server problem. The server may still be available, but because of state information, the entire unit-of-work must be resubmitted

please refer attachement .

Can some one please help me out .
 

Attachments

  • error.jpg
    error.jpg
    27.8 KB · Views: 40

ONYX

Well Known Member
Looks like connection timeout
Check what's in the jdbj.ini (C:\E910\DV910\ini\sbf\jdbj.ini )

My settings
[JDBj-CONNECTION POOL]
connectionTimeout=1800000

Are you trying to get quantities for one item when bssv fails or it fails withing the loop when you call bsfn hundreds/thousands times?

p.s. picture attachment is tiny, can't see anything
 

kishorgite

Member
Thanks ONYX for reply .
I am getting this error when i try to get quantities for one item only.
Getting same error for any BSFN .I can not run any BSFN
oracle.e1.bssvfoundation.exception.BSFNServiceRunt imeException: Server Failure while executing business function. Please try request again.

My setting as below :

[JDBj-CONNECTION POOL]
jdbcPooling=false
minConnection=1
maxConnection=5
initialConnection=1
poolGrowth=1
connectionTimeout=1800000

If any one have document which helps to run BSSV using JDevloper 11g please share it with we on kishorgite048@gmail.com .
 

Chan Rana

Legendary Poster
Looks like you are trying to execute locally on fat client?. If so make sure you have correct settings in you jde & jdbj. Get it from the Enterprise server or contact your CNC. Also look at the jde log to check for more info. To me it looks like the service is not able to execute or ubale to get data.

Also give the E1 details and background of the problem since lot depends on version and how/where you are executing.

Chan
 
Top