• Introducing Dark Mode! Switch by clicking on the lightbulb icon next to Search or by clicking on Default style at the bottom left of the page!

No primary location for some inventory items

rkarnap

Active Member
B7332 10.1 NT

Hello list,

Our client went live a few months ago. Last week we noticed some stock inventory items (stocking type S)that have one or two secondary locations but no primary location. We tried to change one of the locations to a primary, but nothing happened, not even an error message. We tried adding a blank secondary location. When we tried to change the blank secondary to a primary, once again nothing happened.

We called the JDE help desk (call number 4293966). The consultant thought it probably was a data conversion problem at go-live. Also we can't figure out a report or an inquiry that we can use to make a list of the item/branch combinations that have this problem.

Has anyone seen this?

Russell Karnap
russell.karnap@accenture.com
513 455 1355
513 455 3355 fax



J Russell Karnap
 

wsellers

Active Member
Yes it is a data conversion problem. Since "misery loves company", it may
help to know we've had the same problem with our go-live.
One of our consultants did manage to correct a large number of the problem
locations with an SQL; however, we still have a few and they appear to be
isolated to a single branch/plant.

We're preparing to roll out Oneworld to a new branch/plant. I hope it goes
well.



Walt Sellers
Heil Environmental Industries, Ltd.
 
B7332 SP13.3 Client

We went live on 7321 7/99 - just recently 'upgraded' to 7332 about 2 months
ago.

Saw this on one of our items a few weeks ago - don't believe it had anything
to do with upgrade... otherwise I would be seeing this more than once (so
far anyway). Somehow we had two secondary locations for this item and no
primary. And like you said system would not let me change one of those
secondaries to primary.

So I transferred qty from secondary into a location that I had not set up
yet - just got a warning that this location did not exist (we do not use
location master so this is possible). The system automatically assigned
this new location as primary. We have our defaults set to use primary for
FROM and TO on F4113 - Transfers.

Hope this helps. Oh and we developed our own reports to show on hand qty
with P/S location information. You might be able to modify the R41411 -
Select Data for Cycle Count / processing options to include P/S Location.
Since we 'upgraded' all canned reports have medium security and I cannot
check if this is possible but something to look into.

Hope this helps!

Cindy Bramon
Denver Water
 
We had vice-versa problem: item is recorded into primary location without
creating a respective secondary location (we have lot processing on). This
happens during sales transfer between 2 branch/plants if new item
transferred without copying it from FROM B/P to TO B/P. Perhaps you can
investigate in this direction.

The way to correct F41021 is to enter missing records for primary location
trough MS Access or SQL.

I would also suggest to find out the program that created record in F41021
and try to duplicate the problem in order to find the cause.


Alexei Martkovich
Oracle 8i, HPUX, B733.2, SP13.3
 

Hal_McGee

Active Member
A note from a World user.
It is possible in World to create a part without a primary stocking location.
Sounds like you may have the same problem, although you may have gotten there
differently. In World to fix this you go to the Inventory Adjustments screen and
enter a qty of 1 against the part without the Primary Stocking location. This
program will create the default Primary stocking location and put in a quantity
of one. After you have your primary stocking location, then go back and adjust
out the inventory you created to fix the problem.
 

david_mallory

Well Known Member
Russel,

Is your data showing specific locations that should have a P that have an S?
The locations are there, but they have an S?

I also do not see a stock report or screen that will display what you want.

The data is in F41021: LOCN is location, and the P or S is in PBIN (you
may know all this).

I think you need to write a report or use some data retrieval program to
read F41021, sort records by ITM (short item number), and look for a P in
one of the records for each item.

Try adding an item to item master, via the keyboard, and entering a location
when that screen comes up, and then take a look at it. A new item should
come up with a P in PBIN.

Where F41021 shows locations with an S in PBIN that should be P, have your
data base person update a few of them to P, then use the items to do some
transactions, and see what happens.

Dave Mallory Denver Water Denver, Colorado, USA NT 4.0
Oracle 8.05 7332 SP 13.3
 
Top