"No matching project found" when running from server

eydeak

Reputable Poster
Hello,

I have a new UBE and a new Create!form Designer and Director to email the UBE PDF. I'm not an export, but I've done a few simple "email the PDF" projects without problems.

On this one, I'm having an issue when submitting the UBE to the server, I'm not getting my email. The log on the Create!form server shows that it does see the UBE and but then says "No matching project found". I can run the UBE locally and copy the PDF over to our Create!form server and run it through the test function and it works perfectly. The log shows it stepping through the Director steps and I get the email. I've downloaded the server PDF, copied to the Create!Form server and run it through the test function and it gets the same "No matching project found" message in the log.

I've run this by the other guys I work with and it has us all stumped for now. We tried comparing the metadata in the PDFs and it looks the same to us.

Other UBE's which send emails are working fine from the server, including a new one I developed a couple weeks ago.

If anybody has any suggestions as to what else to look for, we'd really appreciate it.

Thanks,
 

KSwaeby

Reputable Poster
Check the "Project Directory" that the CformServer printers are using. The "no form project found" is just telling you that the CformServer printer can't find a matching project to process the job.

Karen.
 

eydeak

Reputable Poster
Sorry, I probably should have mentioned in the original post that I and others have verified that the project does exist in the directory. The Quest TEST function find it with no problems when using the local PDF, but not when using the server PDF. We looked at the metadata for both PDFs and it looks to us like they both have the correct project reference. We thought maybe for some reason the server wasn't creating the metadata correctly, but the metadata looks the same for both.
 

KSwaeby

Reputable Poster
Is your Cdirector project calling a project name that does not exist?

What is name of the .cdp6 and .cfp6 project?

What exactly is the text in the log file? It should be saying more than "project not found"... if not then increase logging so you get more info.

What is the configuration of the CformServer app and the CfServer printer?

What folders are the .cdp6/.cfp6 project files in?
 

eydeak

Reputable Poster
The following is the log from the PDF generated on my JDE fat client. This shows it working.

Job 'R559921C_DTZ00001_local.pdf' started (id 123)
Current license for module JDE Connector found
Loading project C:\DEVdata\DEVworkdir\R559921C.cdp6
Current license for module Director Server found
No headers found
Step 1: DoesDataExist
Step 2: DoesEmailAddressExist
Step 3: IsThisProduction
Step 4: Send TEST Email
Current license for module Print Server found
Step 4 completed successfully
Step 3 completed successfully
Step 2 completed successfully
Step 1 completed successfully
Director project completed successfully
Job 'R559921C_DTZ00001_local.pdf' completed (id 123)


The following is for the log using the PDF generated from the JDE Enterprise Server.

Job 'R559921C' started (id 42)
Current license for module JDE Connector found
Current license for module JDE Connector found
No headers found
Job 'R559921C' started (id 42)
Current license for module JDE Connector found
Current license for module JDE Connector found
No headers found
Job 'R559921C' started (id 42)
Current license for module JDE Connector found
Current license for module JDE Connector found
No headers found
Job 'R559921C' started (id 42)
Current license for module JDE Connector found
Current license for module JDE Connector found
No headers found
Using merge configuration PostScript
Loading module CF6OMPS
No matching project found
Sent direct to printer OK
Job 'R559921C' completed (id 42)

It appears as if the server version can't find the project, even though both PDF's are generated from the same UBE with the exact same data. The only difference is, for the one that works the UBE was executed on my fat client. The one that didn't work was executed on the Enterprise Server. We have many other UBE's which follow this pattern to send email and they are all working fine from the Enterprise server.

I and 2 other people have double checked the folder to make sure my director and designer files are there. There aren't any extra spaces or anything in the file names that might be throwing something off.

I don't know the answer to the configuration questions. I've sent that to the guys who do the server side work and will post their answers once I have them.

Thanks,
 

KSwaeby

Reputable Poster
Increase the logging level on the CformServer printer so you get more detail about what exactly it's doing.

Take the JDE PDF that is generated from E1 and see if you can use it with either CformDesigner or CformDirector. That is just another check to make sure that what is generated from E1 server is valid like the Fat Client PDF is. You could also do the opposite... run the JDE PDF from Fat Client through the CformServer (go into properties of the CformServer printer and use "Test" button).
 

eydeak

Reputable Poster
Thanks. I've asked our server guy about increasing the logging level.

I did open the server PDF in Designer and it behaves strangely there. The PDF view looks normal, but where it is associating the fields it is off. It's hard to describe what it looks like when you select a field. I've tried to attach screen shots of what it looks like for the working local pdf and the non-working server pdf.
 

Attachments

  • DesignerWorks.JPG
    DesignerWorks.JPG
    257.3 KB · Views: 3
  • DesignerDoesntWork.JPG
    DesignerDoesntWork.JPG
    292.6 KB · Views: 5

eydeak

Reputable Poster
We got the logging increased and it produced interesting results. I've attached the full log, but will point out the part where it diverges from the working PDF's log here.

Here is the server non-working log:


'projDir' is C:\DEVdata\DEVworkdir
Before HasProject
HasProject() 'found' is 0
'project' is empty

It doesn't seem to think we have a "project" value in the PDF.

Here is the relevant section from the log for the local PDF which works:

'projDir' is C:\DEVdata\DEVworkdir
Before HasProject
Checking for C:\DEVdata\DEVworkdir\R559921C{_DTZ00001}.cdp6 ...
HasProject() 'found' is 1
'project' is not empty

So, does anybody know something specific to a single UBE running on a server which would affect the "project" value within the PDF?

I've tried opening the PDF and looking at the additional metadata, but can't find anything labeled as "project". And nothing jumps out as being really different about the metadata. I'm not sure what to look at to tell what Create!form is looking at for the "project" value.

Thanks,
 

Attachments

  • VerboseLogServerPDF.txt
    17.2 KB · Views: 1

KSwaeby

Reputable Poster
Looking at the screen shots from CformDesigner I think the JDE PDF generated from your E1 server is different in some way that is causing the problem. Is the JDE.ini file on enterprise server set differently than what is on the fat client?
 

eydeak

Reputable Poster
I can ask a CNC guy to check, but I don't think so. I would think an issue with the jde.ini on the server would affect every UBE running on that server. And the issue is specific to this one UBE.
 

KSwaeby

Reputable Poster
Good point about the problem being specific to this UBE. Maybe something in that UBE is corrupt on the E1 Server. Has it been re-promoted from the client to the server?
 

eydeak

Reputable Poster
Yes, we have redeployed it a few times. I also created a brand new version (in case the problem was with the version and not the base UBE), but the new version behaved the same way. We even went ahead at one point and promoted it from DEV to CRP and it behaved the same way on the CRP server.

There are so few report level settings on the UBE and most of them I never change from the default. The Print Setup is about the only thing we touch when we do Create!form UBEs to point it to the queue which processes the output to the Create!form server.
 
Top