Need help figuring out BI Publisher bursting issue.

bvrancken

Member
Hi Everyone,

I'm trying to set up a BI publisher report for a 9.2 JDE environment that has to send a customer statement to the selected customers, and has to burst into multiple PDF files if more than 1 customer was selected in the data selection...

Attached you can find the xml output of the job. The Burst field is set to:

/R5503B3001/A_R_Detail_Reports_S3_Group/Customer_Level_Break_S7

When we run the report for more than one customer (so when it has to burst the report) the status turns out to "FX" with the following errors in the XML publisher kernel:

5140/6536 Fri Aug 05 07:17:11.928000 XMLPBurstUtils.cpp400
Failure found in burst status file, please see debug log for additional details.

5140/6536 Fri Aug 05 07:17:11.928001 XMLPBurstUtils.cpp402
*** In case of blank reports, the most common cause for this failure is an invalid burst field. ***

5140/6536 Fri Aug 05 07:17:11.928002 XMLPBurstUtils.cpp400
Failure found in burst status file, please see debug log for additional details.

5140/6536 Fri Aug 05 07:17:11.928003 XMLPBurstUtils.cpp402
*** In case of blank reports, the most common cause for this failure is an invalid burst field. ***

5140/6536 Fri Aug 05 07:17:11.928004 XMLPBurstUtils.cpp400
Failure found in burst status file, please see debug log for additional details.

5140/6536 Fri Aug 05 07:17:11.928005 XMLPBurstUtils.cpp402
*** In case of blank reports, the most common cause for this failure is an invalid burst field. ***

5140/6536 Fri Aug 05 07:17:11.928006 XMLPUtil.cpp2742
Unable to read burst status file. Return Code 13

I did already set up a temp directory and added it to the xdo.cfg file on the enterprise server, and still get the same errors.
I can't figure out what is going wrong with the bursting of the report. When just a single customer is selected everything else works properly. Have I set up the burst field incorrectly? Any input would be appreciated.
 

Attachments

  • R5503B3001_TEST1_133.xml.txt
    661.3 KB · Views: 31
  • burstsetup.jpg
    burstsetup.jpg
    115.2 KB · Views: 35

Mike Mackinnon

Well Known Member
We burst on the individual customer number - our variable is "ElectronicAddress_ID67".
This is what our burst field looks like: /RHO03B50/Statement_of_Account_View_S1/ElectronicAddress_ID67


Looking at your XML it seems that the field you are bursting on has no values in it. Maybe give this a try?

/R5503B3001/A_R_Detail_Reports_S3_Group/Customer_Level_Break_S7/AddressNumber_ID2


I think the program will try to burst when the field being bursted on changes values. Maybe it is a problem since this 'field' is not changing?
 
Call Orchestrations From Excel – The Easy Way to Make the Orchestrator Work for You.
Top