• Introducing Dark Mode! Switch by clicking on the lightbulb icon next to Search or by clicking on Default style at the bottom left of the page!

Media object update via SQL

Hi,

Hopefully someone will be able to assist with the issue I am having with media objects in JDE, I am trying to update (F00165) JDE media objects through an Oracle view via SQL.
I am able to read the media object and display the text, however when it comes to updating the media object all seems OK except when viewing in JD Edwards the text displays as what seem to be Chinese symbols. If I select from the F00165 table and convert the text using utl_raw.cast_to_raw(text) the data displays as expected.

Do I need to convert the text when writing it back to F00165? Do I have a character set issue?

The character set currently set on the system are :

NLS_CHARACTERSET = WE8MSWIN1252
NLS_NCHAR_CHARACTERSET = AL16UTF16

Thanks in advance,

Jamie
 

Larry_Jones

Legendary Poster
Jamie,

are you writing the text using Rich Text Format?
are you updating other fields in the F00165 such as text length?
 
Hi alex thanks for the reply, we have previously done this in xe and it worked fine, we are upgrading now to e9 this is where we have the issue. All works ok except when view in JDE.
 
Hi Larry,

Yes the text is written in rich text format via an oracle view. Does the text length field exist in E9 on the F00165? I am not updating this value if it does. I know that this was present in XE and everything worked fine, its only now we are upgrading to E9 we are having issues.

Is this an unicode issue or an issue to do with the character set we have set?

Thanks,

Jamie
 

BOster

Legendary Poster
If you are doing this in 9.0 look at all the jdeGTxxxxxxx api calls in jdekproto.h. Pretty much has everything you need to work with media objects of all types and multiple attachments per key, etc.
 

samantha_sana

Well Known Member
Hi ALL,
I have the same issue to update text in Media object table F00165.
When update with normal update command the text is updated and visible in utb but i found there is diffence in the format as it is missing some extra characters in the blob field.
When viewed from application it looks like chines characters.
Can any one please let me know how to convert this to blob format.

Thanks in advance
 

samantha_sana

Well Known Member
Hi Jamie,
did you update in the BLOB field with plain text through normal update statement or you have converted to BLOB before updating.Please let me know.
I have an issue to update the same media object BLOB field.

Thanks
 
Top