• Introducing Dark Mode! Switch by clicking on the lightbulb icon next to Search or by clicking on Default style at the bottom left of the page!

JAS install classpath

I have completed all install steps upto trying to log onto OneWorld with an html client. I was trying to test my WebShpere configuration before running gen.bat. My stdout log says I have a problem with my classpath. I have looked it over many times trying to find a problem.

I believe the problem is getting Weblogic JDBC drivers configured. Here is a copy of my stdout log.

=============================================

[01.04.17 12:19:37:765 EDT] 5149d2b2 DrAdminServer A DrAdmin available on port 3,013
Load group: WA_OneWorld1
Instantiate: com.jdedwards.jas.ServletProxy
[01.04.17 12:19:39:171 EDT] 5041d2b2 WebGroup X [Servlet Error]-[{0}]: {1}: {2}
"com.jdedwards.jas.ServletProxy"
"Failed to load servlet"
javax.servlet.ServletException: Servlet [com.jdedwards.jas.ServletProxy]: Could not find required servlet class - class com.jdedwards.jas.ServletProxy : java.lang.NullPointerException: Null output stream.class
at javax.servlet.ServletException.<init>(ServletException.java:61)
at com.ibm.servlet.engine.webapp.WebAppServletManager.loadServlet(WebAppServletManager.java:56)
at com.ibm.servlet.engine.webapp.WebAppServletManager.loadAutoLoadServlets(WebAppServletManager.java:117)
at com.ibm.servlet.engine.webapp.WebApp.loadServletManager(WebApp.java:673)
at com.ibm.servlet.engine.webapp.WebApp.init(WebApp.java:83)
at com.ibm.servlet.engine.srt.WebGroup.loadWebApp(WebGroup.java:124)
at com.ibm.servlet.engine.srt.WebGroup.init(WebGroup.java:88)
at com.ibm.servlet.engine.ServletHost.addWebGroup(ServletHost.java:91)
at com.ibm.servlet.engine.ServletEngineDynamicUpdateSupport.addWebGroup(ServletEngineDynamicUpdateSupport.java:124)
at com.ibm.ejs.sm.active.ActiveServletGroup.startAction(ActiveServletGroup.java:76)
at com.ibm.ejs.sm.active.ActiveObject.startObject(ActiveObject.java:663)
at com.ibm.ejs.sm.active.ActiveObject.start(ActiveObject.java:110)
at com.ibm.ejs.sm.active.ActiveObject.operateOnContainedObjects(ActiveObject.java:565)
at com.ibm.ejs.sm.active.ActiveServletEngine.startAction(ActiveServletEngine.java:52)
at com.ibm.ejs.sm.active.ActiveObject.startObject(ActiveObject.java:663)
at com.ibm.ejs.sm.active.ActiveObject.start(ActiveObject.java:110)
at com.ibm.ejs.sm.active.ActiveObject.operateOnContainedObjects(ActiveObject.java:565)
at com.ibm.ejs.sm.active.ActiveEJBServer.startAction(ActiveEJBServer.java:96)
at com.ibm.ejs.sm.active.ActiveObject.startObject(ActiveObject.java:663)
at com.ibm.ejs.sm.active.ActiveObject.start(ActiveObject.java:110)
at java.lang.reflect.Method.invoke(Native Method)
at com.ibm.ejs.sm.agent.AdminAgentImpl.activeObjectInvocation(AdminAgentImpl.java:93)
at com.ibm.ejs.sm.agent.AdminAgentImpl.invokeActiveObject(AdminAgentImpl.java:62)
at com.ibm.ejs.sm.agent._AdminAgentImpl_Tie._invoke(Unknown Source)
at com.ibm.CORBA.iiop.ExtendedServerDelegate.dispatch(Unknown Source)
at com.ibm.CORBA.iiop.ORB.process(Unknown Source)
at com.ibm.CORBA.iiop.WorkerThread.run(Unknown Source)
at com.ibm.ejs.oa.pool.ThreadPool$PooledThread.run(ThreadPool.java:528)

[01.04.17 12:19:39:203 EDT] 5041d2b2 WebApp X Failed.to.initialize.webapp.{0}
"WA_OneWorld1"
javax.servlet.ServletException: Servlet [com.jdedwards.jas.ServletProxy]: Could not find required servlet class - class com.jdedwards.jas.ServletProxy : java.lang.NullPointerException: Null output stream.class
at javax.servlet.ServletException.<init>(ServletException.java:61)
at com.ibm.servlet.engine.webapp.WebAppServletManager.loadServlet(WebAppServletManager.java:56)
at com.ibm.servlet.engine.webapp.WebAppServletManager.loadAutoLoadServlets(WebAppServletManager.java:117)
at com.ibm.servlet.engine.webapp.WebApp.loadServletManager(WebApp.java:673)
at com.ibm.servlet.engine.webapp.WebApp.init(WebApp.java:83)
at com.ibm.servlet.engine.srt.WebGroup.loadWebApp(WebGroup.java:124)
at com.ibm.servlet.engine.srt.WebGroup.init(WebGroup.java:88)
at com.ibm.servlet.engine.ServletHost.addWebGroup(ServletHost.java:91)
at com.ibm.servlet.engine.ServletEngineDynamicUpdateSupport.addWebGroup(ServletEngineDynamicUpdateSupport.java:124)
at com.ibm.ejs.sm.active.ActiveServletGroup.startAction(ActiveServletGroup.java:76)
at com.ibm.ejs.sm.active.ActiveObject.startObject(ActiveObject.java:663)
at com.ibm.ejs.sm.active.ActiveObject.start(ActiveObject.java:110)
at com.ibm.ejs.sm.active.ActiveObject.operateOnContainedObjects(ActiveObject.java:565)
at com.ibm.ejs.sm.active.ActiveServletEngine.startAction(ActiveServletEngine.java:52)
at com.ibm.ejs.sm.active.ActiveObject.startObject(ActiveObject.java:663)
at com.ibm.ejs.sm.active.ActiveObject.start(ActiveObject.java:110)
at com.ibm.ejs.sm.active.ActiveObject.operateOnContainedObjects(ActiveObject.java:565)
at com.ibm.ejs.sm.active.ActiveEJBServer.startAction(ActiveEJBServer.java:96)
at com.ibm.ejs.sm.active.ActiveObject.startObject(ActiveObject.java:663)
at com.ibm.ejs.sm.active.ActiveObject.start(ActiveObject.java:110)
at java.lang.reflect.Method.invoke(Native Method)
at com.ibm.ejs.sm.agent.AdminAgentImpl.activeObjectInvocation(AdminAgentImpl.java:93)
at com.ibm.ejs.sm.agent.AdminAgentImpl.invokeActiveObject(AdminAgentImpl.java:62)
at com.ibm.ejs.sm.agent._AdminAgentImpl_Tie._invoke(Unknown Source)
at com.ibm.CORBA.iiop.ExtendedServerDelegate.dispatch(Unknown Source)
at com.ibm.CORBA.iiop.ORB.process(Unknown Source)
at com.ibm.CORBA.iiop.WorkerThread.run(Unknown Source)
at com.ibm.ejs.oa.pool.ThreadPool$PooledThread.run(ThreadPool.java:528)

Load group: OneWorldJSP
Instantiate: com.ibm.servlet.jsp.http.pagecompile.PageCompileServlet
[01.04.17 12:19:39:421 EDT] 5041d2b2 ServletInstan A Loading.servlet:."jsp"
[01.04.17 12:19:39:703 EDT] 5041d2b2 WebGroup A [Servlet.LOG]:."com.ibm.servlet.jsp.http.pagecompile.PageCompileServlet: init"
[01.04.17 12:19:39:765 EDT] 5041d2b2 ServletInstan A Servlet.available.for.service:."jsp"
Instantiate: com.ibm.servlet.engine.webapp.DefaultErrorReporter
[01.04.17 12:19:39:828 EDT] 5041d2b2 ServletInstan A Loading.servlet:."ErrorReporter"
[01.04.17 12:19:39:843 EDT] 5041d2b2 WebGroup A [Servlet.LOG]:."com.ibm.servlet.engine.webapp.DefaultErrorReporter: init"
[01.04.17 12:19:39:859 EDT] 5041d2b2 ServletInstan A Servlet.available.for.service:."ErrorReporter"


Larry Burroughs
Dewberry & Davis
lburroughs@dewberry.com
703.849.0326
XE, SQL7, SP 14.1 Windows 2000, Update 1
 
Thanks=20

I was aware that it is case sensitve. I have gone over it many times =
and I
also created a text file with the DOS8.3 names and pasted those into =
the
path as you suggested. I can't figure out what I'm doing wrong



Larry Burroughs
Dewberry & Davis
lburroughs@dewberry.com
703.849.0326
XE, SQL7, SP 14.1 Windows 2000, Update 1
 
Hi, Larry,

Seem to me you have problem on specify the CLASSPATH for WA_OneWorld1. Could
you copy the CLASSPATH or the CMD string from WebSphere to me? Also, what is
your JAS installed (NT, AS400 or Unix)?

Regards,

Wilson Chen
Systems Management Inc.
Wilson_Chen@smius.com

Quoting LBurroughs <LBurroughs@dewberry.com>:

(WebAppServletManager.java:56)
(WebAppServletManager.java:117)
(ServletEngineDynamicUpdateSupport.java:124)
(ActiveServletGroup.java:76)
(ActiveObject.java:565)
(ActiveServletEngine.java:52)
(ActiveObject.java:565)
(AdminAgentImpl.java:93)
(WebAppServletManager.java:56)
(WebAppServletManager.java:117)
(ServletEngineDynamicUpdateSupport.java:124)
(ActiveServletGroup.java:76)
(ActiveObject.java:565)
(ActiveServletEngine.java:52)
(ActiveObject.java:565)
(AdminAgentImpl.java:93)
Cat=&Board=OW&Number=9254



Wilson H. Chen
Systems Management Inc.
 
Larry what version of Websphere are you using? If you
are using 3.5 make sure you are putting your classpath
in the command line. There is some old documentation
that tells you to click on the environment button and
put it there. However you must put the classpath in
the command line to make it work.
--- LBurroughs <LBurroughs@dewberry.com> wrote:
javax.servlet.ServletException.<init>(ServletException.java:61)
com.ibm.servlet.engine.webapp.WebAppServletManager.loadServlet(WebAppServletManager.java:56)
com.ibm.servlet.engine.webapp.WebAppServletManager.loadAutoLoadServlets(WebAppServletManager.java:117)
com.ibm.servlet.engine.webapp.WebApp.loadServletManager(WebApp.java:673)
com.ibm.servlet.engine.webapp.WebApp.init(WebApp.java:83)
com.ibm.servlet.engine.srt.WebGroup.loadWebApp(WebGroup.java:124)
com.ibm.servlet.engine.srt.WebGroup.init(WebGroup.java:88)
com.ibm.servlet.engine.ServletHost.addWebGroup(ServletHost.java:91)
com.ibm.servlet.engine.ServletEngineDynamicUpdateSupport.addWebGroup(ServletEngineDynamicUpdateSupport.java:124)
com.ibm.ejs.sm.active.ActiveServletGroup.startAction(ActiveServletGroup.java:76)
com.ibm.ejs.sm.active.ActiveObject.startObject(ActiveObject.java:663)
com.ibm.ejs.sm.active.ActiveObject.start(ActiveObject.java:110)
com.ibm.ejs.sm.active.ActiveObject.operateOnContainedObjects(ActiveObject.java:565)
com.ibm.ejs.sm.active.ActiveServletEngine.startAction(ActiveServletEngine.java:52)
com.ibm.ejs.sm.active.ActiveObject.startObject(ActiveObject.java:663)
com.ibm.ejs.sm.active.ActiveObject.start(ActiveObject.java:110)
com.ibm.ejs.sm.active.ActiveObject.operateOnContainedObjects(ActiveObject.java:565)
com.ibm.ejs.sm.active.ActiveEJBServer.startAction(ActiveEJBServer.java:96)
com.ibm.ejs.sm.active.ActiveObject.startObject(ActiveObject.java:663)
com.ibm.ejs.sm.active.ActiveObject.start(ActiveObject.java:110)
com.ibm.ejs.sm.agent.AdminAgentImpl.activeObjectInvocation(AdminAgentImpl.java:93)
com.ibm.ejs.sm.agent.AdminAgentImpl.invokeActiveObject(AdminAgentImpl.java:62)
com.ibm.ejs.sm.agent._AdminAgentImpl_Tie._invoke(Unknown
com.ibm.CORBA.iiop.ExtendedServerDelegate.dispatch(Unknown
com.ibm.ejs.oa.pool.ThreadPool$PooledThread.run(ThreadPool.java:528)
javax.servlet.ServletException.<init>(ServletException.java:61)
com.ibm.servlet.engine.webapp.WebAppServletManager.loadServlet(WebAppServletManager.java:56)
com.ibm.servlet.engine.webapp.WebAppServletManager.loadAutoLoadServlets(WebAppServletManager.java:117)
com.ibm.servlet.engine.webapp.WebApp.loadServletManager(WebApp.java:673)
com.ibm.servlet.engine.webapp.WebApp.init(WebApp.java:83)
com.ibm.servlet.engine.srt.WebGroup.loadWebApp(WebGroup.java:124)
com.ibm.servlet.engine.srt.WebGroup.init(WebGroup.java:88)
com.ibm.servlet.engine.ServletHost.addWebGroup(ServletHost.java:91)
com.ibm.servlet.engine.ServletEngineDynamicUpdateSupport.addWebGroup(ServletEngineDynamicUpdateSupport.java:124)
com.ibm.ejs.sm.active.ActiveServletGroup.startAction(ActiveServletGroup.java:76)
com.ibm.ejs.sm.active.ActiveObject.startObject(ActiveObject.java:663)
com.ibm.ejs.sm.active.ActiveObject.start(ActiveObject.java:110)
com.ibm.ejs.sm.active.ActiveObject.operateOnContainedObjects(ActiveObject.java:565)
com.ibm.ejs.sm.active.ActiveServletEngine.startAction(ActiveServletEngine.java:52)
com.ibm.ejs.sm.active.ActiveObject.startObject(ActiveObject.java:663)
com.ibm.ejs.sm.active.ActiveObject.start(ActiveObject.java:110)
com.ibm.ejs.sm.active.ActiveObject.operateOnContainedObjects(ActiveObject.java:565)
com.ibm.ejs.sm.active.ActiveEJBServer.startAction(ActiveEJBServer.java:96)
com.ibm.ejs.sm.active.ActiveObject.startObject(ActiveObject.java:663)
com.ibm.ejs.sm.active.ActiveObject.start(ActiveObject.java:110)
com.ibm.ejs.sm.agent.AdminAgentImpl.activeObjectInvocation(AdminAgentImpl.java:93)
com.ibm.ejs.sm.agent.AdminAgentImpl.invokeActiveObject(AdminAgentImpl.java:62)
com.ibm.ejs.sm.agent._AdminAgentImpl_Tie._invoke(Unknown
com.ibm.CORBA.iiop.ExtendedServerDelegate.dispatch(Unknown
com.ibm.ejs.oa.pool.ThreadPool$PooledThread.run(ThreadPool.java:528)
com.ibm.servlet.jsp.http.pagecompile.PageCompileServlet
[Servlet.LOG]:."com.ibm.servlet.jsp.http.pagecompile.PageCompileServlet:
[Servlet.LOG]:."com.ibm.servlet.engine.webapp.DefaultErrorReporter:
http://198.144.193.139/cgi-bin/wwwthreads/showflat.pl?Cat=&Board=OW&Number=9254


=====
Michael Moorman
7009 Wallace Ave.
Cincinnati, OH 45243
513-604-6786

__________________________________________________
 
Hi Wilson

My JAS is installed on Windows 2000, WebSphere 3.5. Here is a copy of my CMD string. You wouldn't believe how many times I have checked this. It just seems to me that the problem should be in the CMD string. I was wondering about the date of my jas.jar file. It is dated 8/13/2000 7:54AM.

================================================

-Xbootclasspath/a:C:/WebSphere/AppServer/lib/servlet.jar;
E:/JDEdwardsOneWorld/B7333/internet/jas/collections.jar;
E:/JDEdwardsOneWorld/B7333/internet/jdewww/owjava/jdeifc112.jar;
E:/JDEdwardsOneWorld/B7333/internet/jas/redist.jar;
E:/JDEdwardsOneWorld/B7333/internet/jdewww/share/xml.jar;
E:/JDEdwardsOneWorld/B7333/internet/jas/OWResource.jar;
E:/JDEdwardsOneWorld/B7333/internet/jas/debug_jas.jar;
E:/JDEdwardsOneWorld/B7333/internet/jas/jas.jar;
C:/WebSphere/AppServer/classes/weblogic

There are no carriage returns in my CMD string I just posted this way so it could be read better

================================================

Thanks
Larry


Larry Burroughs
Dewberry & Davis
lburroughs@dewberry.com
703.849.0326
XE, SQL7, SP 14.1 Windows 2000, Update 1
 
I assuem you are on SP14.2 and up. If that is the case, try this:

-mx256m -ms256m -noclassgc
-Xbootclasspath/a:C:/WebSphere/AppServer/lib/servlet.jar;
E:/JDEdwardsOneWorld/B7333/internet/jas/JAS.jar;
E:/JDEdwardsOneWorld/B7333/internet/jas/XPIe_SAW.jar;
E:/JDEdwardsOneWorld/B7333/internet/jas/redist.jar;
E:/JDEdwardsOneWorld/B7333/internet/jas/collections.jar;
E:/JDEdwardsOneWorld/B7333/internet/jas/Debug_Jas.jar;
E:/JDEdwardsOneWorld/B7333/internet/jas/OWResource.jar;
E:/JDEdwardsOneWorld/B7333/internet/jdewww/share/xml.jar;
C:/WebSphere/AppServer/classes/weblogic

Samething, there are in one line and no spacing after -Xbootclasspath.

Good luck!

Wilson

Quoting LBurroughs <LBurroughs@dewberry.com>:

Cat=&Board=OW&Number=9293



Wilson H. Chen
Systems Management Inc.
 
Re: RE: JAS install classpath

I have a question. While reviewing my WebSphere setup instructions from JDE under the section "Creating a Web Application for the OneWorld Java Server".
======================================
*Web Application Name WA_OneWorld_1
Description OneWorld Web Application
*Virtual Host VH_OneWorld_1
*Web Application Path
======================================
.Full Web Path: Delete the default value and leave it empty. Do not leave the "/"

Every time I remove the "/" from the Web Application Path it comes back as soon as you click apply or restart the Web App.

Is WebSphere supposed to behave this way and if so is this an error in the JDE installation guide. My Installation guide is March 2001 OneWorld Java Server Installation Guide and I am referring to page 42.



Larry Burroughs
Dewberry & Davis
lburroughs@dewberry.com

XE, SQL7, SP 14.1 Windows 2000, Update 1
 
Re: RE: JAS install classpath

The answer is Yes, it is behave to put a "/" even you remove it.

Wilson

Quoting LBurroughs <LBurroughs@dewberry.com>:

Cat=&Board=OW&Number=9380



Wilson H. Chen
Systems Management Inc.
 
Re: RE: JAS install classpath

Well I might be on to something here. I have had this issue open with JDE for the past week. Nobody has bothered to ask me what version of WebSphere, or what OS this running on. BTW its WebSphere 3.5 and Windows 2000 server. After doing more research at the knowledge garden I found an article referencing SP14_JAS cd for instructions on installing JAS w/WebSphere 3.5. This might be a problem for me since the only cd I have is the JAVA server cd 9/18/2000 Control#1521. I wasn't aware and don't even have a SPXX_JAS service pack cd. I'll let you know what I find out when I get a call back from JDE.

Larry Burroughs
Dewberry & Davis
lburroughs@dewberry.com

XE, SQL7, SP 14.1 Windows 2000, Update 1
 

jarrieta

Member
Re: RE: JAS install classpath

You are absolutely right. Support for Websphere 3.5
started with JAS Server CD SP14. The JAS Server CD
Shipped with Xe is SP 13 and does not support
Websphere 3.5. Unfortunately for you, JDE expired
JAS_SP14.1 You are going to have to go to SP15 and
JAS_SP15. The date on your JAS.JAR must be about the
same as the JDECOM.DLL (day or two off).

Jorge Arrieta


--- LBurroughs <LBurroughs@dewberry.com> wrote:
http://198.144.193.139/cgi-bin/wwwthreads/showflat.pl?Cat=&Board=OW&Number=9437


__________________________________________________
 
Top