• Introducing Dark Mode! Switch by clicking on the lightbulb icon next to Search or by clicking on Default style at the bottom left of the page!

Iway Adaptor for EnterpriseOne Xe on Iseries

Devki

Active Member
We are on JDE Enterprise One Xe running on Iseries DB2/400 V6R1 M0
We are testing the IWay integration tool.
My understanding is that we should be modifying the JDE.ini on the Enterprise Server as follows:
[JDENET_KERNEL _DEF6]
krnlName = Call OBJECT KERNAL
dispatchDLLName=XMLCallObj
dispatchDLLFunction=XMLCallObjectDispatch
maxNumberOfProcesses=1 (this # is default)
numberOfAutoStartProcesses=1 (this # is default)

[JDENET_KERNEL _DEF15]
krnlName = XML TRANSACTION KERNAL
dispatchDLLName=XMLTrans
dispatchDLLFunction=XMLTransactionDispatch
maxNumberOfProcesses=1 (this # is default)
numberOfAutoStartProcesses=1 (this # is default)

Is there any other place in the system, either on the Enterprise server or Deployment server or the client machines, changes should be made to get the adaptor working?
 

KSI

Active Member
Are you sure you want to spell the kernel name with an 'A' ?
I also recommend all caps and no spaces around the equal:
krnlName=CALL OBJECT KERNEL
krnlName=XML TRANS KERNEL
 

agreenejde

Active Member
These are what I had for those definitions when we were on XE on an AS400:

[JDENET_KERNEL_DEF6]
krnlName=CALL OBJECT KERNEL
dispatchDLLName=XMLCALLOBJ
dispatchDLLFunction=XMLCallObjectDispatch
maxNumberOfProcesses=30
numberOfAutoStartProcesses=1

[JDENET_KERNEL_DEF15]
krnlName=XML TRANSACTION KERNEL
dispatchDLLName=XMLTRANS
dispatchDLLFunction=XMLTransactionDispatch
maxNumberOfProcesses=20
numberOfAutoStartProcesses=1
 

Devki

Active Member
Thanks for the information. Did you have to change any other files on the Deployment server and or Terminal Servers? Also i did not add JDENET_KERNEL_DEF16 ie XML list. Is this needed?
 
Top