Issue with Standalone install on non supported Windows OS

Michael L.

Well Known Member
Hello List. Hoping you can share any ideas regarding an issue with Standalone on a Windows Server 2008 R2 Standard with SP1. I understand this is not a supported configuration. Having said that we have a similar setup for regular 9.0 J.D. Edwards so we can have multiple user’s logged in concurrently and use J.D. Edwards without having same installed on their fat client.

I have searched MOS and found a few doc id’s which talked about making sure the port is 6012, possible change to the host file and making sure tnsnames.ora is in the proper locations and copied from the Standalone_9.10\client, that there’s no extension on the hosts file name, that the path environment variable is correct and in our case - C:\JDEdwards\E910_1\DEMO\bin32;C:\JDEdwards\E910_1\system\bin32;C:\Oracle\product\11.2.0\client_1\bin;c:\Oracle\E1Local\bin;

It appears the database and client installed without issue but I can’t get past the error - cannot contact security server. I’m not so sure this isn’t a misleading error only because the tnsnames.ora is in the proper folders and that’s all I could find on security server but don’t know for sure.

I’ve tried many combinations in the security stanza of ip, localhost and port #’s according the tnsnames.ora file but still no luck.

I’ve attached the the jdedebug log files, it quite small.

This is my hosts file

# For example:
# # source server
# # x client host

# localhost name resolution is handled within DNS itself. localhost

And this is my tnsnames.ora file

# Please edit this file to add the necessary oracle database
# E1LOCAL is required (Local Oracle Database)


(SID = PLSExtProc)

And the Security / JDENET stanza in the jde.ini file

DataSource=System Local
Default Role=*ALL


Any ideas would be much appreciated.

Thanks in advance,

9.0,, V6R1, OAS


  • 187437-jdedebug_3772_040414.txt
    53.5 KB · Views: 19
Hello Michael,
I am success to build a VM with Standalone Demo 9.1 on Windows 2008 R2 SP1. As suggestions, you need check if the E1local database runs well by using cmdlet “lnsrctl status”. Normally there are two service instances “E1localXDB” and “e1local” listening on the 1521 port. Use cmdlet “tnsping E1local” to check the database connection. In addition, make sure that you have closed the IPV6 function of Windows and get the result by pinging localhost. Set securityserver to localhost instead of Bring up the JDE demo and wait for at least 10 seconds before push the OK button to go. Hope those can help to resolve your issue.
Hello Dale. Thanks for responding to the post. Glad to hear you have this setup working. I'm pretty much a hard core '400' guy and not as strong on the WINTEL platform. Anyway, I tried what you recommended and all was successful so this still remains a mystery. Oracle tried to help (before I posted on JDELIST), but was not able to and eventually gave up because of the non supported OS. If you can think of anything else or if I can attach anything else to this post, please let me know.

Thanks again,

9.0,, V6R1, OAS
The key part of the install is taking the tnsnames.ora file from your E1Local install and copying it to your Oracle Client - the 32bit client is what is used for connection, but it doesn't get a tnsnames file created by default. This is exactly the same as with a regular fat client, and I have run both on Win2008 R2 (64bit) successfully.