• Introducing Dark Mode! Switch by clicking on the lightbulb icon next to Search or by clicking on Default style at the bottom left of the page!

Issue applying Fix Current through Change Assistant

Soumen

Reputable Poster
Dear List,

Has anyone encountered the below error while trying to apply fix current through Change Assistant.

I am trying to apply fix current to our DV910 environment using change assistant and for some unknown reasons the change assistant keeps crashing with a message saying "JAVA(TM) Platform SE binary has stopped working" . I have attached a screen shot of the error message to the SR. An attempt to restart the Change Assistant and restart the deployment process again also results in the same error.

However if we restart the deployment server the Change assistant usually allows us to restart the deployment again but fails after applying some ESU's again with the same message. This is not allowing us to proceed with our important activity related to Fix Current. Any help or guidance will be appreciated.

Change Assistant version: 3.0
JRE 1.6
Application Release: 9.1
Tools Release in DV: 9.1.5.5
Deployment Server OS: Windows 2008 R2.
Enterprise Server: iSeries V7R1

I was able to use CA to apply fix current to PS910 sucessfully just a few weekes back with no such issues.
The Deployment server does seem to have received any updates or patches related to JAVA.

Any help will be appreciated.

Thanks,
Soumen
 

Attachments

Tom_Davidson

VIP Member
Soumen,

I've haven't tried using CA to apply ESU's in years. I was never able to get it to work.

That being said, I'm wondering if it has anything to do with the ESUs already being on your system. Check for logs named jas_###.log and jderoot_###.log in the root of your C: drive. They may help.
 

Soumen

Reputable Poster
Thanks for the response, I checked those logs did not see any entries during for the timestamp I am getting that crash message.
 

altquark

Legendary Poster
You might want to consider downloading and installing the newer Change Assistant from edelivery.oracle.com

There are instructions that are in the ZIP file that show that you can use a 64bit JRE to run Change Assistant now. This should help a lot with lots of issues we've all experienced in the past.
 

glen7x

Active Member
Soumen, couple of things that you can try -
- Rebooting the deployment server and then restarting the process. (I see that you have already tried this)
- Change the jre version to 1.7, 32 bit ofcourse.
- Reistalling the CA.

If its failing for the same ESU over and over again, install and apply this ESU manually and then continue the process. I have been using change assistant over the years and find it very convenient.
 

Soumen

Reputable Poster
@Glen: I have tried all of them with no success.
@Jon: There was a new version of CA released on 10/05 and I deleted my JAva cache and it was installed. But this new version 3.0.10 also gave me the same errors. Infact now I am getting errors while trying to apply any ESU through P96470 which throws a warning message right at the very end. (Attached)

I am working with Oracle support, let's see what they come up with.

Thanks for all the response.
 

Attachments

cdawes

VIP Member
Change assistant works fine. I don't understand why anyone would not use it. In fact it's been rock solid for years.

I'm guessing I installed this system..............

and can guarantee I didn't sit around and tap buttons. I would have just said "apply 1000 ESUs" and then went and did something else.

The biggest issues are when people forget that CA is 32 bit. NEVER install a 64 bit JVM for CA.

Also you should be on a 1.7 JVM and not 1.6 now.

Also best to do fix current on the baselines first and then the rest of the ESUs. This gets the big ESUs out of the way and minimizes the chance of a crash.

Then do the rest.

Of course with big batches it will ALWAYS crash after about 400 ESUs.

Just kill Solution Explorer, all the Java processes for CA and then restart CA and resubmit the btach (or create a new one). Either way it will just pick up where it left off.


Colin
 

Soumen

Reputable Poster
Thanks for your reply Colin. Yes it is the S&S system installed by you. :)

Well I had some marathon calls with Oracle developemnt and they traced the problem not with Change Assistant but with the a function call for BSFN B96705.

The problem occurs when any ESU (either applied from CA or P96470) calls one of the function inside this BSFN which makes a call to SY910.F9672. Right then it throws an warning message saying the BSFN failed. CA was displaying a JAVA crash but this was the actual cause of the crash.

What is baffling is that the bsfn B96705 was not touched since 2012 and we have applied 1000's of ESU's since then. A workaround was provided where they commented out the section on code where it makes the call to the F9672 on System. With that commented out the ESU application and CA both works fine. The only downside being the records are not getting updated to SY910.F9672. I was asked to copy over the records from Local to SY910 for the time being to keep them in sync.

With that function commented out I just finished appying more than 1000 ESU to DV using CA. But we still don't know how/what caused the errors to the function calls to F9672.

We have already tried re-generating that table in System - 910 but no success.

Thanks,
Soumen
 

sameiben

Member
i have installed change assistant 3.0.10 with jre 1.8 in 3 diffrent places for 9.1 and no issue, you might want to try jre 1.8
 
Top