Inventory Interop Problem

Saad Faisal

Hi Everyone

I have a DEMO environment for E910 (Tools I am trying to a do single Inventory Item import in order to learn about Z Tables. I have inserted a record from the P4101Z1 app through the Web Interface with following values in the columns

1. (TNAC) Transaction Action = "A"
2. ITM = 568568
3. LITM = 56856801
4. AITM = 56856802
5. DSC1 = "Saad Item 2"
6. STKT (Stocking Type) = (Some Value from UDC 41/I)
7. TYTN (Transaction Type) = JDEITEM
8. DIRIN (Direction Indicator) = 1

Using the FAT Client , i ran the "Working with Batch Versions - Available Versions" and use the program R4101Z1I. I specified my Data Selection criteria to select this specific row and Submit it. The PDF got generated but the specific row is not processed. I have tried to identified the reason through the R4101Z1I_*.log file and it seems there are row inserted in F01131M that says 'Error: Invalid Characters Found'. Can anyone please help me out, what i am doing wrong ? any help would be greatly appreciated.

I have attached the Log file for reference as well. For more info i have this DEMO E910 setup on a Windows 7 x64 VM.

Saad Faisal


    213.3 KB · Views: 59

Processing the Z files can be tricky. I am used to loading data directly into the tables and then processing. We often had issues with extra / missing space (' ') characters and justification issues.

Since you used the web client, you should be okay. I skimmed one of the logs and noticed the following -

Mar 25 22:39:00.393148 - 1456/3396 UNKNOWN ORACLE DBRsetReq conn=070B0C08 requ=08C60398 localhost (E1Local)
Mar 25 22:39:00.393150 - 1456/3396 UNKNOWN Exiting JDB_SelectKeyed with Success
Mar 25 22:39:00.393151 - 1456/3396 UNKNOWN ORACLE DBFetch conn=070B0C08 requ=08C60398 maxrows=1
Mar 25 22:39:00.393152 - 1456/3396 UNKNOWN No More Data found
Mar 25 22:39:00.393153 - 1456/3396 UNKNOWN There is no record for user 'ABPOWUSER' in security table
Mar 25 22:39:00.393154 - 1456/3396 UNKNOWN Added user [DEMO], clientIP [], remotePid [5548] to the logon user list
Mar 25 22:39:02.452000 - 1456/5244 UNKNOWN About to call dispatch function, flags=0x2, Type=555

Does ABPOWUSER have the correct permissions to execute the UBE ?

- Robert
Thanks ROB for the quick response, can you guide me as how i can check this particular user's rights ? second dont you think if rights is the case , it shouldnt have generated the PDF in the first place ?

Waiting for your response

Saad Faisal
Seems that the log file is truncated and does not therefore show the real error?
Hi Aarto

Yes you are right , here is another file of the debug log, really appreciate if you can help me identify the issue.

Best Regards
Saad Faisal
can anyone assist please ?
The log shows two errors:

Cause. . . . . The first character at the cursor is not valid as used. The
first character of the Item Number can not be one of the
characters specified in your Constants File(F41001).
Resolution . . Change the first character to be one other than one specified
in your Constants File(F41001). If your Constants File
specifies that '*' and '/' are valid characters for your
Second and Third Item Numbers, then either use a blank in
front of your Item Number or a special character other than
'*' or '/'.



CAUSE. . . . . If foreign currency is on, the cost level cannot be a value
of '1' (item level).
RESOLUTION . . Enter either a value of '2' (item/branch level) or a value
of '3' (item/branch/location/lot level).
Hi Craig

Thanks for your response, based on your suggestion, i tried the following

1. For "2571" Error, i modified the SZLITM and SZAITM columns with prepending them with a space character.

2. For "3754" Error, i updated SZCLEV with '1' and later with '2' and '3' as well.

But to no avail, and the entry was not processed. Here is the update Query that i ran.

update JDEData910.F4101Z1 set SZLITM=' 56856801', SZAITM=' 56856802',SZCLEV='1' where SZEDBT in (16255);

Any other ideas. I have attached the Log as well for convenience.
Hi Everyone, i was able to resolve the issue with the Craig's direction and a little bit of moving around, however i am stuck on another area.

Now i want to transfer my entries from a Flat File using the
R47002C batch app. I have a relative encoding setup in my P93081 with a UTF-8 format and my file is also properly formatted as well, however here is the thing

When i run the P47002C program with the XJDE0005 version number, my entries only get transfered to my F4101Z1 table but it seems that the R4101Z1I batch app somehow fails to transfer the rows. But confusing part is that at this point i can manually run the R4101Z1I and it will successfuly transfer those rows to my F4101 Item Master table. I am quite confused on what is going on here ?

Any ideas or clues, i am attaching my flat file and the logs for reference. Reviewing the "Work Center" shows that

CAUSE. . . . An attempt was made to load a program with an incorrect format.
RESOLUTION. . Check format.

But as i said, if you run separately R4101Z1I the rows gets inserted successfuly so i am not sure who to blame in this situation. I have attached the Flat File and Log for reference, any help would be appreciated.


    6.4 KB · Views: 38