• Introducing Dark Mode! Switch by clicking on the lightbulb icon next to Search or by clicking on Default style at the bottom left of the page!

Invalid Overwrite or Read

G

Guest

Guest
Hi all

My problem is as follows;

We have made extensive mods to P4210 (something I once swore never to
do !!) and generally speaking we have managed to iron out all the
problems. However, I keep getting an error on TS workstations where
the job gets the Invalid Overwrite or Read error message and locks up.
This only happens on TS, thick clients seem to be immune. The main
problem I have is – where is the error occuring ? I cannot put the
application into debug because of random occurences and the TS
environment. The closest we have come is to get a log off two of the
jobs. Prior to these messages, everything appears to be running
smoothly.

Is there anyone out there who can tell me which object er is crashing
from the following logs? Is this even an er problem or is it related
to memory (?) on the TS ?

Log #1
Jan 08 15:14:47 ** 820/1007 [Invalid Overwrite or Read] The system may
become unstable.Please debug the Application using the Event Rule
Debugger.
Application:p584210 Event :Button Clicked [T:3ef
F:D:\b7\system\jdeuser\jdedlg\DLG_MSGB.CPP Ln:191 Lv:LEVEL1]

Log #2
Jan 08 13:42:46 ** 874/2406 RT: <<<Finished ER: Enter Row App:
Form: W584210A [T:966 F:D:\b7\system\jdeuser\jdecgrt\RT_ER.cpp Ln:2781
Lv:LEVEL3]

Jan 08 13:42:48 ** 874/2406 [Invalid Overwrite or Read] The system may
become unstable.Please debug the Application using the Event Rule
Debugger.
Application:p584210 Event :Button Clicked [T:966
F:D:\b7\system\jdeuser\jdedlg\DLG_MSGB.CPP Ln:191 Lv:LEVEL1]

Any help/comments will be appreciated. There is a 150m cement silo
next to building I am in and a swallow dive from the top is starting
to look very inviting !!

Regards

Andre


System : HP 9000 UNIX, Oracle 8.05, OneWorld 7332, SP 10.1
_______________________________________________________________
http://www.webmail.co.za the South-African free email service
WIN R10 000 by registering for free online options for EasyMoney in
http://www.easyinfo.co.za/easymoney/wmindex.asp - Easy Does it - Now!!!
 

HolderAndrew

Well Known Member
I have had a lot of these! Here's a few ideas:

1. Delete all debug entries (delete all *.dia files from d:b7/pathcode/bin32) if they exist, on the TS.

2. Ensure that all BSFNs have been built in optimise mode. Check the CSALES.DLL has the same size on the TS to the Deployment server. If they are different then I suggest that you rebuild it. Also check the other parent DLLs.

3.The 3rd possibility is that you have some user overrides relating to an old screen format. Delete the overrides from F98950 for try again.

I hope one of these works.

Andrew Holder

Technical Development Specialist
Developing World Systems Ltd
JDE Consulting Partner of the Year 2000 - SUMAH Region
+ 44 (0)1494 896600 Switchboard
+ 44 (0)1494 896603 Direct
+ 44 (0)1494 896611 Fax

andrew.holder@dwsystems.co.uk
Xe SP13, AS400 V4R4,
 

Zoltan_Gyimesi

Legendary Poster
Hi Andre,

Change your settings in the jde.ini file of workstations or in the appropriate one on WTS:

[DB CACHE INFORMATION]
Library CACHE=20

If this entry does not exist then insert it.

This setting could correct many random memory violation error, hopfully could correct yours too.

Good luck,
Zoltán

B7332 SP11, ESU 4116422, Intel NT4, SQL 7 SP1
(working with B7321, B7331, XE too)
 
Hi there, I'm also having an issue with invalid overwrites and reads. I built a custom application, and as far as I can tell everything is programmed fine.

If I open and close the application 10 or 15 times it will give me the invalid overwrite or read error. I dont even have to try and change data, or click on any controls, it just crashes.

This is running on a terminal server, in Xe update 7, backend server is db2 as400.

Any suggestions?
tks
 
Top