How do i create a Business Library?

anandkj_jde

Member
Dear List,

I created a Business Function and attach it to
CALLBSFN and it worked fine. I created a library.
I did add a business function and when i compiled thru
bus build. It displayed the following error. I have
created the business library with the default options.

Generating Makefile: D:\B7\DV7333\obj\B55BL.mak
Makefile generated.

Building business functions.
 

Zoltan_Gyimesi

Legendary Poster
Hi K.J. again,

At first can you tell us at least your OneWorld release level (or the other system informations like SP level, etc. too)?

Different problems and different solutions exist when you create a custom BL object under different OW releases (mainly XE and earlier).

How did you started BusBuild? From Object Librarian, from Object Management Workbench (in this case with wich button?), external from OneWorld with "Run" (in this case what kind of settings have you made)?

Please, let us more to help you more. Thanks.

Zoltán

B7332 SP11, ESU 4116422, Intel NT4, SQL 7 SP1
(working with B7321, B7331, XE too)
 

Zoltan_Gyimesi

Legendary Poster
Excuse me. I have forgotten to ask for your BusBuild error(s).
I see only:
======================================================================
Generating Makefile: D:\B7\DV7333\obj\B55BL.mak
Makefile generated.

Building business functions.
======================================================================
in your post on the Forum.

Regards,
Zoltán

B7332 SP11, ESU 4116422, Intel NT4, SQL 7 SP1
(working with B7321, B7331, XE too)
 

anandkj_jde

Member
Following is the error i get in

I used OMW, created a Custom Library in the name of
B55BL. I further did not choose any options - left it
to defaults and clicked on OK. I got a Library to my
project.After which i did add a function to this
library and when i compiled it using busbuild i got
the following error.

Please Advice.

Thanks in Advance

K.J.Anand Kumar
WINNT 4, NT-SP6, OneWorld Xe 7333, SP 14, AS/400.



Generating Makefile: D:\B7\DV7333\obj\B55BL.mak
Makefile generated.

Building business functions.
 

Zoltan_Gyimesi

Legendary Poster
Hi K.J. again,

As I see you have sent again your post to [email protected] and to [email protected] too. (Note: Eric do not like posts sent to "[email protected]"!)
I have got both as e-mail. The strange thing that only one containes the complete BusBuild list the other ends with:
==================================================
Generating Makefile: D:\B7\DV7333\obj\B55BL.mak
Makefile generated.

Building business functions.
==================================================
again, further this one appeared on the Forum only.

How did you attached the list to your post. Try to copy/paste to NotePad and copy/paste it from NotePad to your post. (... and do not send to "[email protected]" only to "[email protected]"!)

You have not answered that which button did you started the build with on the Design Tools tab of the BSFN.
1.) Build Business Function
2.) Busbuild standalone

My suggestion for you:

1.) Try the second button. If fails again then try second time. If my memory serve me well it was a solution once upon a time.
2.) if 1st fails then run BusBuild outside from OneWorld (log-off OW before).
On NT System:
* use the "Run..." from the Start menü
* Locate your BusBuild in your B7 folder (e.g.: "E:\b7\SYSTEM\Bin32\Busbuild.exe")
* start it
* Select the "Build All..." from Build menu
* mark the "Select Specific DLLs to Build"
* Hit "Select", hit "Clear All", select your custom DLL, hit OK
* Mark the "Generate Missing Source Report" and the "Generate Source for NER & TER", leave the others check-box unmarked.
* Hit "Build" and pray.
* If fails then repeat it second time again.

If it fails again then:
A.) Copy the "CDIST.exp", "CDIST.lib" and "sCDIST.lib" in the "lib32" folder replacing "CDIST" with "B55BL" (with the name of your custom DLL) in the file names. NOTE: You can copy any other three file instead CDIST, e.g. CFIN too.
B.) Repeat steps 1 and 2 if necessary.

Please, let us know you results. If you will success, then please, describe at which step.

Good Luck,
Zoltán
P.S.: Please, do not send your post to the "[email protected]" address as I asked you recently replying you privately. Thanks! Believe me, totally enough to send it to "[email protected]" only. Everybody will receive it and it will be appear on the Forum too.

B7332 SP11, ESU 4116422, Intel NT4, SQL 7 SP1
(working with B7321, B7331, XE too)
 

anandkj_jde

Member
Thanks a heap Zoltan,

I was sucessful in creating the CUSTOM DLL. Your Tip

On NT System:
* use the "Run..." from the Start menü
* Locate your BusBuild in your B7 folder (e.g.:
"E:\b7\SYSTEM\Bin32\Busbuild.exe")
* start it
* Select the "Build All..." from Build menu
* mark the "Select Specific DLLs to Build"
* Hit "Select", hit "Clear All", select your custom
DLL, hit OK
* Mark the "Generate Missing Source Report" and the
"Generate Source for NER & TER", leave the others
check-box unmarked.
* Hit "Build" and pray.

worked perfectly fine with me.

Thanks Again.

Cheers,
K.J.Anand Kumar
OneWorld XE, SP14 , AS/400, WINNT4 - SP6


PS: Sorry about the REPLY ALL.

======================================================

--- Zoltan_Gyimesi <[email protected]> wrote:
http://198.144.193.139/cgi-bin/wwwthreads/showflat.pl?Cat=&Board=OWDEV&Number=15151


=====
Regards,

K.J.ANAND KUMAR
---------------
SYSTIME COMPUTER SYSTEMS LTD
CHENNAI,INDIA.

__________________________________________________
 

Zoltan_Gyimesi

Legendary Poster
Hi K.J.,

Thanks for your update. I am really glad that could help you a bit and because you let me know your success before my 3 weeks long holiday.

Just an addition:
Once you build first time your custom DLL on a workstation or on the deployment server and deployed it to a full development workstation, you can use the "Build Business Function" button on Design Tools tab of the BSFNs in the OMW to re-compile/build any modified or new BSFN in this DLL. You do not need to rebuild the entire DLL again on the workstation except when you changed the DLL for a BSFN.

Regards,
Zoltán

B7332 SP11, ESU 4116422, Intel NT4, SQL 7 SP1
(working with B7321, B7331, XE too)
 
Top