• Introducing Dark Mode! Switch by clicking on the lightbulb icon next to Search or by clicking on Default style at the bottom left of the page!

Global RV problem in UBE

Zoltan_Gyimesi

Legendary Poster
Hi List / Forum,

Unfortunately I am not experienced with RDA.
Please, let me first describe my task briefly.

I have to modify the Fixed Asset Depreciations making usable in Hungary. One of the effected object is R12855 "User Defined Depreciation" UBE. I placed some new global RV onto the "On mnFiscalYearLevelBreak_FLFY" Level break header section.
I have a logic that I have to refresh and/or Show/Hide these fields and setup a lot of things when F12851 Depreciation Rules changes. I have to make it when this section first time run and in the "F1201/F1202 Join - UDD Journal" primary hidden section when it detects break programaticaly on F12851 Depreciation Rules (I have to do many others but they aren't relevant for this issue).
So, I have a bunch of logic which have to be performed at to place.
I hate to duplicate the code, so I deciede to create a Conditional Hidden Group section to encapsulate the code in the Do Section event of it and call this section on the two place in the Do Section event of the both section.

My problems are:
1.) I can not set the mentioned global RVs on the Level break header section, the values does not appears on it.

2.) Debugging the UBE, it seems so that my conditional section isn't invoked by the Do Custom Section calls but executed only once, at the end of the report.

3.) My conditional and hidden section cause an extra and empty page on the end of the report, containing only the report header.

4.) I can issue a Hide/Show for this RVs of the Level break header section outside of this section (e.g. in my conditional or in the original primary). Validates are successfull but cause error at runtime: "UNKNOWN CONTROL_ID IN HIDE/SHOW SYS.FUNCTION:: 1208" and the execution is failed.

Of course, I tried these with the original fields of the level break header too. Of course also that I created new version.
I always ran the UBE locally on my developer machine.

Current Platform: XE SP 15.1

Are they already known issues? Could it be SP level dependent?

Any help, information will be greatly appreciated, mainly when somebody will try to reproduce my scenario on other SP level and will report her/his results.

Many thanks in advance,
Zoltán


Current Platform: XE SP 15.1

B7332 SP11, ESU 4116422, Intel NT4, SQL 7 SP1
(working with B7321, B7331, XE too)
 

Zoltan_Gyimesi

Legendary Poster
Hi Forum / List,

It seems so that my 1st, 2nd and 3rd problem resolved. 4th is open yet.

Brrrrrrrrrrrrr.....
Do you want to know how in this WonderfulWorld?
The labels of Conditional and Page Break After check boxes are inverted on the Advanced tab of the section properties window.

Please, check the attachment of this post on the Forum. See the labels on the right and the help texts on the left.

WYSIWYDG: What You See Is What You Don't Get?
Maybe sometimes we have to missbelieve that we see with our eyes?

BE CAREFUL!

Zoltán
Current Platform: XE SP 15.1


B7332 SP11, ESU 4116422, Intel NT4, SQL 7 SP1
(working with B7321, B7331, XE too)
 

Attachments

Frosty the Coder

Legendary Poster
Zoltan,

From past experience the HIDE/SHOW only works on fields in the same
section. It _does_ pass the ER validation, but gives the errors you've
described. I've set a rpt_cWork_EV01 in the one section, and checked
it in the section for the hide/show.

Watch out for the HIDDEN fields in rda, they often make the WYSIWY_don't_G.

Hope this helps.

Gene



Gene Piekarski, Jr

AS/400, B733, SP11.2, NT client
AS/400, B733, SP14, W2000 client
XE, SP13
 

Zoltan_Gyimesi

Legendary Poster
Hi Gene and Forum/List,

First, thank you Gene for your test and reply.

The Conditional/Page Break After reversing is SP 15 related issue and will be corrected in SP 16.
Please check the ott-01-0048 "Advanced Section Properties Reversed in RDA for a Group Section after Installing SP 15" documentation and the SAR# 4945415 "Advanced Properties Group Sect SystemH91" on the Knowledge Garden.

Reading this documentations, now I uderstand why haven't I found them while I haven't figured out the problem myself. I had problem with Conditional Section (I supposed), so I searched for "Conditional Section" in some context and alone. I didn't searched for "Conditional" only because I supposed, I will get a bunch of hits. While I haven't figured out the problem, there was no reason to search for Page Break After.

Regards,
Zoltán

B7332 SP11, ESU 4116422, Intel NT4, SQL 7 SP1
(working with B7321, B7331, XE too)
 
Top