F4111 and commit failures

amwalshjde

Well Known Member
We are getting an error when we try to create various inventory transactions
(for example, inventory transfer). The error occurs when the program tries
to update the Item ledger (f4111). The error we get is that the commit
failed and to look in the jde.log When I do I see an error message for a
duplicate key. I then go to my jdedebug.log and see where it is doing the
insert. First thing I notice is that there are two sql insert statements
back to back in the log. Should there be? If I cut one of them out, and
pasted into SQL and run it, it worked fine, and it was added to the F4111.

I know about the F00022 file and the R4111UK Program. I already ran the UBE,
and then went back and manually (via P00022) and made the value in the
F00022 be higher then the highest in the F4111. Still no luck. I also
noticed that each time I treid to write a record to the F4111, the value in
the F00022 got higher even though it never wrote to the F4111. So now my
value in the F00022 is several numbers higher then the highest number in the
F4111, is that normal?

Any assistance would be appreciated.

B7332 sp 13.1 AS/400 v4r5 (new from v4r4 a week ago) and NT app servers.
Mix citrix and fat client, with problem persisting on both.

Thanks
Aaron


_________________________________________________________
 

Andre_Jille

Active Member
We had the same problem 2 weeks ago, the only solution was to delete all sql
packages on the AS/400, except the ones beginnen with a 'Q'.

Kind regards,
André
 

amwalshjde

Well Known Member
Thanks, Andre. One more question

Where are the SQL packages on the as/400, and what are the steps required to
delete them?

Thanks again,
Aaron
 

KBohn

Active Member
That's interesting. We are getting commit failed errors intermittently on
Purchase Order Entry P4310. We have been working with JDE to try to
resolve, but so far no luck. We used to get it sometimes when making
changes to PO's & we were told that the Pre-Req ESU 4605023 would fix it.
Well, we no longer get it when making changes to PO's, now we get it when
entering PO's & we have to re-enter the entire PO. Does anybody else get
this?

Regards,
Kimberley Bohn
QNX Software Systems Ltd., Canada
B73.3.2, NT, SQL7.0, SP11.3
WTS W2K
 

amwalshjde

Well Known Member
Re: RE: F4111 and commit failures

I should have also mentioned that it works in some environments but not all. (which is why I am convinced it is related to the unique key id). I also found the document (ID # OTI-99-0072) on what SQL packages are, and how to delete them. We will have to wait till tonight to try it as all users must be signed off, and network services have to be down.
 

vikas_paliwal

Active Member
Aaron,

I have experienced similar issues. One major problem is that applications
like Inventory transfers do not have a Commit/Rollback feature. This should
be basic functionality throughout OneWorld, but it is not. This is supposed
be fixed in a future release of Xe.

Now, our particular problem with why it is occurring is partially our fault.
We have programs/applications that were developed using tools like VB. But
we did not design these to use any J.D. Edwards business functions. What
happens in this case, is that the tables encounter a SQL level lock, which
OneWorld does not look for. OneWorld keeps track of record locks in F00095,
I think. Both OneWorld and our programs were hitting the F00022 at the same
time, resulting in the F41021 being updated and not the F4111 for OneWorld
transactions.

I am not sure if this helps!

Vikas

B7331 SP11.3/SQL7.0/NT4.0/Citrix




_________________________________________________________



--------------------------
 

Leroy

Active Member
Hi Kimberly,

We are also getting Commit fails intermittently. We seem to be geting them
in Creditors Vouchers. The log is saying that the SQL statement is in use.
JDE haven't been able to shed any light on the problem. They are saying that
it could be a timeout issue, a problem with sql on the AS400 or an alien.

I'm hoping its the Alien because I think that will be easier to get rid off
than the other two. I suspect it could be that we are getting a delay in
updating the database at the same time as the user continualy clicking the
OK button. This may be causing the SQL statement to duplicate, but I'm only
guessing at the moment. Let me know if you get any decent information on the
problem.

Regards

Lee Richards
Chief Technology Officer
Blackmores Ltd

(OW XE, AS400 V4.5, Windows 2000, Citrix)
 

PetSur

Member
Problem was due to corrupt F4105. This was converted date and the purchasing/inventory flags were not set in the table.
 
Top