ESU Deploy failing with database connection


Reputable Poster
We are on E1 9.0, tools release 8.98.42.

We are having problems deploying an ESU using either Change Assistant or the Electronic Software Update application on GH9612 on our deployment server. We've downloaded the ESU but when we try to deploy using either method it fails.

When using Electronic Software Updates from GH9612, it fails and the Table Conversion Workbench screen is displayed showing a Conversion Program Failed error, program R98403XB, error code 089C.

In the jde.log, it shows 'JDB_CopyXMLToTable failed - GT92002'. It also shows some sort of databse connect failed error. 'Databse Connection failed for DataSource Data Dictionary - 900'.

We have opened a ticket with Oracle but their response of changing some ini settings hasn't helped.

Note that the last time we deployed an ESU was january 2013 and had no issues. We have however built and deploy many packages to DV and PD environments also without issue. There have been no server or database changes that we can tell in our system, so baffled as to what is going on at this point.

Any ideas would be appreciated.

Log to your Deployment server as JDE on the
JDEPLAN environment, then launch UTB and try to open
any of the Data - Dictionary 900 tables (like F9200)
Are there any errors?
Yes, Sebastion, I can sign on the JDEPLAN environment as JDE on the deployment server and when I go to UTB I can pull up date in the F9200 from Data Dictionary - 900. No issues there.
By the way, Oracle seems to be pointing to jdbj.ini settings as the issue and we've changed various settings, but we have several versions of jdbj.ini in JDEdwards/E900, so not sure we are looking at the right one. We are looking at and have modified the one in E900\system\oc4j\j2ee\home\applications\webclient.ear\webclient\web-inf\classes. Though there is also one in E900\planner.
I have seen this issue caused by having the incorrect SQL and DB2 jdbc drivers under the \E900\misc folder. Also here are some docs on MOS that might help

Information and Known Issues on Data Dictionary Glossary Merge UBEs R98403 and R98403XB
E1: ESU: Troubleshooting Known Errors And Issues With UBE R98403XB - Load XML Data to Table Document 1072809.1
E1: ESU: CONNECTION_MANAGER_BOOT_ERROR When Trying To Run R98403XB And Going Into ESU Application Document 1550421.1
E1: ESU: "Unable to Fetch Specs for version 'XJDE0052' of Template 'R98403'" Message When Installing an ESU for Which Impact Analysis Was Previously Run Document 1266278.1
Thanks John,

We've looked at that first document. Along with other things we've read, the drivers in that E900\misc were reviewed. Its stated in those or similar documents that the only thing in the E900\MISC should be ojdbc5.jar and sqljdbc.jar

Initially our E900\MISC has ojdb5.jar and a few other files. sqljdbc.jar was nowhere on our deployment server. But then our deployment server has been running fine for 2 years since we upgraded from Xe to 9.0. We have downloaded and deployed the ESU for the last 2 years as well as countless package promotions also.

I did however follow Oracle/JDE advice and downloaded the latest sqljdbc from mircrosoft and placed that in the E900\misc folder. No effect, still fails with the same errors.

I have tried using both sqljdbc.jar and sqljdbc4.jar. Still no effect.