• Introducing Dark Mode! Switch by clicking on the lightbulb icon next to Search or by clicking on Default style at the bottom left of the page!

Erroneous details after accessing JDE Table from VC++6.0

Hi List,

We have succeded in linking with the JDEKERNEL dll and
have fetched the records from a custom table.However
we found the values fetched through the structure had
the following discrepancy. The first character of a
string field was truncated and the first two
characters of the second string field was
truncated.But the numeric values remained intact. What
could be the problem? Please advise.

Regards
BABU

NT WORKSTATION SP5
ONEWORLD XE DEMO


--- jastips <jastips@hotmail.com> wrote:
> Hi ,
>
> The error you are getting because you haven't linked
> the libs. I have a document which can help you to do
> setting in NT environment. If you are still trying
> for that let me know. I can send you that doc.
>
>
> Jastips
> JDE CNC Consultant
> DTI
> USA
> --------------------------
> Visit the forum to view this thread at:
>
http://198.144.193.139/cgi-bin/wwwthreads/showflat.pl?Cat=&Board=OWDEV&Number=7206
>
> + - - - - - - - - - - - - - - - - - - - - - - - - -
> - - - - +
> This is the JDEList One World / XE Developers
> Mailing List.
> Archives and information on how to SUBSCRIBE, and
> UNSUBSCRIBE can be found at http://www.JDELIST.com
> + - - - - - - - - - - - - - - - - - - - - - - - - -
> - - - - +
>


__________________________________________________
Do You Yahoo!?
Yahoo! Auctions - Buy the things you want at great prices.
http://auctions.yahoo.com/
 

mikem

Member
It looks like you might have the byte alignment set to 8 bytes (default)
rather than 1 byte (JDE recommendation)

Under Visual Studio->Project setting, choose the C/C++ Tab. Under the
Code Generation category make sure you have:

Processor: Blend *
Calling Convention: __stdcall (__cdecl is default)
Structure Member Alignment: 1 byte (8 is default)

Regards

Mike
 

jastips

Active Member
Hi,

I am doing the same thing. But I am getting good results. Please check the following you may find any solution.

1) what will be the OW length of the fields and where you are trying to catch those values. If you are assigning those values into any variable check the length. And if you have a idea how to debug then it will exactly show you what is the value of that then you can come to know where the problem is. If you don’t mind if you send me that code I can give you better picture.


Jastips
JDE CNC Consultant
DTI
USA
 
Hi List n Mike,

Thanx a Heap Mike,Jasti n List. Yes! It works after
this setting made to VC++ 6.0.


--- mikem <mike.maguire@tamro.com> wrote:
> It looks like you might have the byte alignment set
> to 8 bytes (default)
> rather than 1 byte (JDE recommendation)
>
> Under Visual Studio->Project setting, choose the
> C/C++ Tab. Under the
> Code Generation category make sure you have:
>
> Processor: Blend *
> Calling Convention: __stdcall (__cdecl is default)
> Structure Member Alignment: 1 byte (8 is default)
>
> Regards
>
> Mike
>
>
>
>
>
> --------------------------
> To view this thread, visit the JDEList forum at:
>
http://198.144.193.139/cgi-bin/wwwthreads/showflat.pl?Cat=0&Board=OWDEV&Number=7286
>
> + - - - - - - - - - - - - - - - - - - - - - - - - -
> - - - - +
> This is the JDEList One World / XE Developers
> Mailing List.
> Archives and information on how to SUBSCRIBE, and
> UNSUBSCRIBE can be found at http://www.JDELIST.com
> + - - - - - - - - - - - - - - - - - - - - - - - - -
> - - - - +
>


=====
Regards,

K.J.ANAND KUMAR
---------------
SYSTIME COMPUTER SYSTEMS LTD
CHENNAI,INDIA.

__________________________________________________
Do You Yahoo!?
Yahoo! Auctions - Buy the things you want at great prices.
http://auctions.yahoo.com/
 
Top