E9.0 OMW Run HTML application issue

jimmymac

Reputable Poster
I am an old OneWorld XE developer, now working with E9.0. I am having trouble when working with Forms design in OMW.

When I go into Forms Design and want to run the application, I choose the Run HTML option. What is supposed to happen I presume is that the application is started via the web client and you see the application displayed as it would on the web.

However, when I choose that option it starts the web browser but then fails with an error 'Unknown JAS sign in error occurred. Please contact the system administrator'. I've tried it when I was already signed on to the web client in our DEV environment, and also not being signed in. Same results. Choosing Run HTML attempts to start the app via the web but fails.

I've looked in my logs in on my fat client and see nothing.

At this point, not even sure where to start looking but would appreciate any ideas or insight. Thanks.
 

jimmymac

Reputable Poster
A companion question. When in Interactive Versions on the fat client, you have the options Run and Run HTML. Run HTML gives the error described above.

If I choose Run, I get a pop up that says 'The application/version is not supported on the windows client. Please use the WEB Client to access the application/version'. Is there any way to circumvent this message and run an application the old non-web way?
 

craig_welton

Legendary Poster
It sounds like your local web dev is not properly configured. There are several Oracle docs about troubleshooting and setting that up. It's worth gaining an understanding of the inner workings of the java app server. The jas and jderoot log files will tell you what is wrong, for the most part. You will be using Websphere Express or OAS depending on your sites setup. CNC delivers the proper one when defining features to deploy with your packages.

As for question 2, the column SIANSIF in F9860 holds the flag to allow an app to run in the Windows client. If it's a W, the app is only runnable on the web. Understand that some applications will ONLY run on the web as they use the newer power forms or other features.

Craig
 

BOster

Legendary Poster
We always had issues running APPLs directly from OMW or from FDA (actually, don't know if I ever tried that). If you have your local web dev configured correctly you can launch the HTML client from activeConsole.exe (Tools|EnterpriseOne Menu). You can then use fast path or menus to launch your APPL. When making APPL changes I just keep the HTML client up and running, as long as you exit out of the form/APPL in the HTML client, the next time you launch it, the HTML client will Javagen on the fly any changes you made and saved in FDA - makes for very rapid development. There are maybe a few things that don't Javagen on the fly correctly but it is rare - actually I can only think of one off hand. If you have any interpreted NERs (client only NERs) and you make a change to the NER I have found that they don't always trigger a re-Javagen of the interpreted NER. In fact I sometimes have to exit all the way out and manually Javagen the client only NER.
 
Discover how to build no-code data integrations and business process automations.

jimmymac

Reputable Poster
Thanks all,

Actually as we look further, it seems we have only probably installed the fat development client, not the web development client. I believe that is a separate or additional piece to the development install, isn't it? That being a separate procedure, is that a pretty straitforward process?

Thanks again.
 

craig_welton

Legendary Poster
Yes, it's a separate installation step that can be included as a package feature. It is in the \OneWorld Client Install\ThirdParty\WebDevFeature directory on the dep server (Websphere or OAS). There is some setup required (JDBC drivers, INI config, JDK etc.) so review the Oracle docs.

Craig
 
Top