E812 standalone problem with web application access

veejay

Member
Hi, I am kinda new here, this is my first thread posting. Please excuse me, if I doesn’t sound right, in any manner. Can somebody please help me with my E812 standalone situation

I had successfully install E812 standalone on my system, but i am unable to access web applications, which I tried to access through TOOLS->EnterpriseOne Menu of JDE solution explorer. I got this Error: ‘An unknown JAS sign in error occurred. Please contact the System Administrator’.

My jdbj specs are as follows, its location is “C:\E812\system\OC4J\j2ee\home\applications\webclient.ear\webclient\WEB-INF\classes”
[JDBj-JDBC DRIVERS]
ORACLE=oracle.jdbc.driver.OracleDriver
#AS400=com.ibm.as400.access.AS400JDBCDriver
#SQLSERVER=com.microsoft.sqlserver.jdbc.SQLServerDriver
#UDB=COM.ibm.db2.jdbc.app.DB2Driver

My JDE log says

5108/4200 MAIN_THREAD Wed Jul 01 15:31:43.394002 ipcmisc.c299
process 5108 <"C:\E812\system\bin32\jdenet_n.exe"> registered in entry 0
5108/4768 FOREIGN_THREAD Wed Jul 01 15:31:46.331005 jdeksec.c770
INITIALIZING SECURITY SERVER KERNEL
5108/4768 FOREIGN_THREAD Wed Jul 01 15:31:46.378004 Netpub.c839
JDENet already initialized
5108/4768 FOREIGN_THREAD Wed Jul 01 15:31:46.378007 Jdb_ctl.c2674
Net init failed or not initialized
1168/3944 MAIN_THREAD Wed Jul 01 15:31:55.566077 Jdb_omp1.c586
JDB9900245 - Failed to find F98611 OneWorld Local in cache
1168/3944 MAIN_THREAD Wed Jul 01 15:31:55.566079 Jdb_rq1.c1795
JDB3100011 - Failed to get location of table F989999 for environment DEMO812
1168/3944 MAIN_THREAD Wed Jul 01 15:31:55.566082 Jdb_utl1.c11609
JDB9900603 - Failed to open table F989999
1168/3944 MAIN_THREAD Wed Jul 01 15:31:56.378097 Jdb_omp1.c586
JDB9900245 - Failed to find F98611 OneWorld Local in cache
1168/3944 MAIN_THREAD Wed Jul 01 15:31:56.378099 Jdb_rq1.c1795
JDB3100011 - Failed to get location of table F989999 for environment DEMO812
1168/3944 MAIN_THREAD Wed Jul 01 15:31:56.378102 Jdb_utl1.c11609
JDB9900603 - Failed to open table F989999

My LOCALWEB_JDEDEBUG says
Jul 01 15:31:55.566 - 1168/3944 bHasDict = 1 bAppServerUp = 0
Jul 01 15:31:55.566 - 1168/3944 Calling JDB_SpecClear API directly....
Jul 01 15:31:55.566 - 1168/3944 Calling JDB_ClearSpec() return code: (null)
Jul 01 15:31:56.378 - 1168/3944 bHasDict = 1 bAppServerUp = 0
Jul 01 15:31:56.378 - 1168/3944 Calling JDB_SpecClear API directly....
Jul 01 15:31:56.378 - 1168/3944 Calling JDB_ClearSpec() return code: (null)
Jul 01 15:31:59.206 - 1168/3944 Http send request failed. Web application server may not be up
Jul 01 15:31:59.206 - 1168/3944 web application server is signaled to start.
Jul 01 15:32:05.191 - 1168/3944 Internet Explorer path from registry is: %programfiles%\Internet Explorer
Jul 01 15:32:09.972 - 1168/3944 Ping response is: <html> Ping Success </html> Jul 01 15:32:09.972 - 1168/3944 Composed URL is: http://localhost:8888/jde/servlet/com.jdedwards.runtime.virtual.LoginServlet?jdelogindecryptor=X&jdeloginvalue=%0b%2b%28%18%49%16%09%09%4f&Environment=DEMO812&Role=*ALL
Jul 01 15:32:09.972 - 1168/3944 ce71e9662982</bstrEngineID><bstrDebugID SOAP-ENV:encodingStyle="http://schemas.xmlsoap.org/soap/encodin URL is: http://localhost:8888/jde/servlet/com.jdedwards.runtime.virtual.LoginServlet?jdelogindecryptor=X&jdeloginvalue=%0b%2b%28%18%49%16%09%09%4f&Environment=DEMO812&Role=*ALL
 

klwong

Legendary Poster
Last I remember, E1 8.12 StandAlone used the MSDE database?

Your section of the JDBJ drivers indicates that the only active driver is the one for Oracle. You'll need to find your MS SQL Server 2000 JDBC drivers, and copy them to \E812\system\OC4J\j2ee\home\applib.

Then you'll have to modify that section to uncomment the SQLSERVER line, and make it say: SQLSERVER=com.microsoft.jdbc.sqlserver.SQLServerDriver, because the way you have it set is for the SQL Server 2005 driver.
 

veejay

Member
First of all thanks for the quick response Ken.

Actually, I have SQL Server 2005 in my system, which I should have mentioned it earlier. Now, Should I install SQL server 2005 JDBC drivers or SQL server 2000 JDBC drivers, and, do I have copy them into \E812\system\OC4J\j2ee\home\applib.
 

sab

Member
You can see the message in the JDE Log:
"Failed to find F98611 OneWorld Local in cache",
Check, please, your jdbj.ini, located in the \system\OC4J\j2ee\home\applications\webclient.ear\webclient\WEB-INF\classes, sections [JDBj-BOOTSTRAP DATA SOURCE] and [JDBj-SPEC DATA SOURCE], values of "database" in both sections. The string must look like this:
database=EnterpriseOne Local
Or you have to create and correctly setup an ODBC data source with the name equal to the database value ("OneWorld Local" I think).
 

klwong

Legendary Poster
1) Please check in your Management Studio that you have the proper databases attached and can see the data in the tables.
2) Your JDBJ.INI had the SQLSERVER line correct for SQL 2005, except for the "#" sign in front which commented the line out. You should remove it to activate that line.
3) Yes, your JDBC drivers are supposed to go in the APPLIB directory. If you are on SQL 2005, then you'll need the MS JDBC driver for SQL 2005, currently version 1.2.
4) Since you are using SQL 2005, you'll have to check that the ODBC entry was created correctly. It's quite likely that it was created using the normal SQL Server ODBC driver instead of the SQL Native Client. If true, then you'll have to delete it and recreate it with the correct driver.
5) Hopefully, you've installed the right version of Java SDK, and copied the files to \E812\system\JDK.
6) Also, hopefully, you've got a version of StandAlone with a Tools Release that can handle SQL 2005. The original release used TR 8.96, and wouldn't be able to do it. There was a later release with TR 8.97, which would be able to do it. However, the JDK would be different for each TR, 1.4.2 vs. 1.5.x.
 

veejay

Member
Thanks for help, I appreciate it.
Last night, I was working with E812 standalone trying to fix my problem, giving trial and error method here & there and while doing so I lost my patience and end up deleting E812 standalone from my system and later installed fresh E900, and I did what they asked me to do in instructions, but it seems like I end in same situation(“Sign In Error: An unknown JAS sign in error occurred. Please contact the System Administrator. See the JASDebug log for details”), no luck. Even though, I install E900, but for some reasons my enterprise folder is named as E812(rather than E900).
I checked System DSN of ODBC DataSource Administrator, it has EnterpriseOne SSELocal(Name) and SQL Native Client(Server). I will attach my JDE.ini, JAS .ini, JDBJ files and jde.log
My computer software release specs are
Windows XP home, SP2. IE 8
Application release E900, Tool release 8.98.3

JAS.ini, C:\E812\system\OC4J\j2ee\home\applications\webclient.ear\webclient\WEB-INF\classes
Sqljdbc, C:\E812\system\OC4J\j2ee\home\applib, C:\E812\MISC (this file was in two locations)
JDBJ, C:\E812\MISC
[JDBj-BOOTSTRAP DATA SOURCE]
name=System Local
databaseType=X
server=(local)
serverPort=
database=EnterpriseOne SSELocal
physicalDatabase=JDESY
owner=dbo
lob=false
unicode=true
databaseInstance=JDESSELocal

[JDBj-SPEC DATA SOURCE]
name=Versions Local
databaseType=X
server=localhost
serverPort=3372
database=EnterpriseOne SSELocal
physicalDatabase=JDEVL
owner=dbo
lob=false
unicode=true
databaseInstance=JDESSELocal
user=sa
password=

[JDBj-JDBC DRIVERS]
ORACLE=oracle.jdbc.driver.OracleDriver
#AS400=com.ibm.as400.access.AS400JDBCDriver
SQLSERVER=com.microsoft.sqlserver.jdbc.SQLServerDriver
#UDB=COM.ibm.db2.jdbc.app.DB2Driver

Apart from above problem, I have one more situation and that one is ‘I can’t build business functions’
Here is the build error
*************Error:************
Current local conditions indicate that compiler -- Microsoft Visual Studio 8.1 -- must be installed with correct paths recorded in the registry.

Either the correct compiler is not installed, registry paths are incorrect, or one of the compiler tools may be missing.

Please contact an administrator to resolve this problem.

Executables needed: nmake.exe, cl.exe, link.exe, lib.exe, dumpbin.exe
---------------- SafetyCheck Started ---------------
Scanning C:\E812\DEMO\include\B0000167.h...
Scanning C:\E812\DEMO\source\B0000167.c...
---------------------- Done ----------------------
2 Files Processed
0 Errors
0 Warnings
 

Attachments

  • 147853-jde.txt
    6.6 KB · Views: 142

klwong

Legendary Poster
I trust you have Visual Studio 2005 installed?
Also, JDK 1.5.x installed, since you are now on E900?

It likely installed into E812 because you deleted the files and directories, and didn't do a proper uninstall. I wonder if it can't find the JDBC driver because of that? Try creating a \E900\MISC directory, and copy the JDBC driver into there.

Your JDE.LOG and JAS.LOG files would be helpful too.
 

veejay

Member
Ken, it seems like there was JDBJ file installation problem, Earlier I overwrote E900 on E812. So what I did this time is, I uninstalled this E900 in a proper way and then install fresh E900. This time, I did’nt do any mistakes with JDBJ, everything went fine, and now I can able to access Web Client without any Errors.

Thanks for all your support & suggestions.

Now, I would like to set complier for Business function build. In E900 installation document, they said “if you plan to build business fuctions, you will need the complier and additional libraries that visual studio provides. I have Visual Studio 2008 on my system.

Does anyone know how to set complier and additional libraries on E900 standalone through visual studio 2008.

My build error message is
*************Error:************
Current local conditions indicate that compiler -- Microsoft Visual Studio 8.1 -- must be installed with correct paths recorded in the registry.

Either the correct compiler is not installed, registry paths are incorrect, or one of the compiler tools may be missing.

Please contact an administrator to resolve this problem.

Executables needed: nmake.exe, cl.exe, link.exe, lib.exe, dumpbin.exe
---------------- SafetyCheck Started ---------------
Scanning C:\E900\DEMO\include\B3400680.h...
Scanning C:\E900\DEMO\source\B3400680.c...
---------------------- Done ----------------------
2 Files Processed
0 Errors
0 Warnings
 

klwong

Legendary Poster
Please be aware that Visual Studio 2008 is not specified on the Technical Requirements yet. The development PC section of the MTR document specifically states to downgrade your Visual Studio 2008 to Visual Studio 2005 SP1.
 

kk_jde

Active Member
Guys, I have the same issue. Running E1 9.0 Demo on Vista with local Oracle Database...getting the same error trying to build a BSFN. What is the resolution for this? Can you please help?
 

raghubhat

Member
Did find the solutions for this issue? I have same problem. Tried playing with jde.ini file and jdbc drivers. Please let me know.
Thanks,
 

finger

Member
There are two solutions:
1.modify your jde.ini file,add following information after keyword [JDE_CG]
VisualStudioVersion=9
(” 9 ” – MS Visual Studio C++ 2008)

2.if [1] dosn't work, you have to uninstall visual studio 2008 and install visual studio 2005 pro version
 
Top