• Introducing Dark Mode! Switch by clicking on the lightbulb icon next to Search or by clicking on Default style at the bottom left of the page!

correct steps to install platform pack 9.2

tot

Member
hi dear
i finished from install deployment server 9.2
and now am working on install Platform Pack on ENT server But i face the Issue
(cannot spawn command %1%)
can u guide me on correct steps
1- install database 12c enterprise on D:\ with Database Character AL32UTF8 this only support in my version
2-install Platform Pack on D:\ then chose FULL
Could to complete the correct steps with prerequisite software
 

Attachments

JDEE1Tips

Well Known Member
There Is no one try Install New Application and tools Release 9.2 ??????????????
Hi Tot,

Hope you are doing great!!!

We like to share our Experience with you in Installation of JD Edwards Platform Pack with Oracle 12c DB.

When we installed JD Edwards E920 on Oracle 12c DB with pluggable DB container enabled we faced the exact error message "(cannot spawn command %1%)"

We created Oracle DB SID as JDE920 and Pluggable container as PDBJDE920. When we tried to install Plartform Pack we provided SID as JDE920 in OUI installer and we got this error message.

We check it in support portal and found the below document as per the document If pluggable DB enabled while installing Oracle 12c DB ,OUI installer looks for pluggable DB SID(PDBJDE920) for JD Edwards Plartform Pack Installaion.

E1: INST: EnterpriseOne Platform Pack Fails with Error "ORA-01918: user 'JDE' does not exist" on Windows 2012 with Oracle 12c Pluggable Database (Doc ID 2065289.1).

Hope this help you!!!

Best regards
JDEE1Tips
www.JDEE1tips.com
 

altquark

Legendary Poster
Run the Platform Pack Setup program as Administrator. Also ensure that you have installed the 32bit Oracle client (if Oracle is being used) and the correct JDK per the pre-requisites.
 

tot

Member
the same error message "(cannot spawn command %1%)"

thanks Dear for support
i flow bellow steps
1- delete the old database And Create new one by SID JDE920 And disabled for pluggable DB container on d:\ drive
2-Run the Platform Pack Setup program as Administrator i provided SID as JDE920 and full installation in OUI installer and other option is default (next)
3- install JDK 32bit (jre-7u40-windows-i586.exe)
2-install Platform Pack and Oracle 12c DB on same Machine on same drive d:\
and after that i get the same error message "(cannot spawn command %1%)"
any help please ???




Hi Tot,

Hope you are doing great!!!

We like to share our Experience with you in Installation of JD Edwards Platform Pack with Oracle 12c DB.

When we installed JD Edwards E920 on Oracle 12c DB with pluggable DB container enabled we faced the exact error message "(cannot spawn command %1%)"

We created Oracle DB SID as JDE920 and Pluggable container as PDBJDE920. When we tried to install Plartform Pack we provided SID as JDE920 in OUI installer and we got this error message.

We check it in support portal and found the below document as per the document If pluggable DB enabled while installing Oracle 12c DB ,OUI installer looks for pluggable DB SID(PDBJDE920) for JD Edwards Plartform Pack Installaion.

E1: INST: EnterpriseOne Platform Pack Fails with Error "ORA-01918: user 'JDE' does not exist" on Windows 2012 with Oracle 12c Pluggable Database (Doc ID 2065289.1).

Hope this help you!!!

Best regards
JDEE1Tips
www.JDEE1tips.com
 

JDEE1Tips

Well Known Member
thanks Dear for support
i flow bellow steps
1- delete the old database And Create new one by SID JDE920 And disabled for pluggable DB container on d:\ drive
2-Run the Platform Pack Setup program as Administrator i provided SID as JDE920 and full installation in OUI installer and other option is default (next)
3- install JDK 32bit (jre-7u40-windows-i586.exe)
2-install Platform Pack and Oracle 12c DB on same Machine on same drive d:\
and after that i get the same error message "(cannot spawn command %1%)"
any help please ???
Dear Tot,

Lets troubleshoot the issue. Please attach the installactions.log and ORCL log from the below location.

Install Action Log Directory : C:\Program Files (x86)\Oracle\Inventory\logs
ORCL Log Directory : C:\JDEdwardsPPack\E920_1\ORCL\logs

Check your DB JDE920 Installed correctly by following steps.

1. Try to ping DB using command "tnsping JDE920"
2. Try to login into DB using SYS userid by using below command

cmd> Sqlplus
username:sys@JDE920 as sysdba
Password:<DB sys/system Password>

Hope we will be able to help you!!!

Best Regards
JDEE1Tips
www.JDEE1Tips.com
 

tot

Member
attach the installactions.log

Hi Dear
thanks for your interest
1-Kindly Find Attach Install Action Logs Directory : C:\Program Files (x86)\Oracle\Inventory\logs
2-About ORCL Log Directory d:\JDEdwardsPPack\E920_1\ORCL\logs not found any logs
the path that i have is D:\JDEdwardsPPack\E920\inventory (not found ORCL folder )
3-About connection is OK and connect successful and kindly find attach jde920_connection.doc

Dear Tot,

Lets troubleshoot the issue. Please attach the installactions.log and ORCL log from the below location.

Install Action Log Directory : C:\Program Files (x86)\Oracle\Inventory\logs
ORCL Log Directory : C:\JDEdwardsPPack\E920_1\ORCL\logs

Check your DB JDE920 Installed correctly by following steps.

1. Try to ping DB using command "tnsping JDE920"
2. Try to login into DB using SYS userid by using below command

cmd> Sqlplus
username:sys@JDE920 as sysdba
Password:<DB sys/system Password>

Hope we will be able to help you!!!

Best Regards
JDEE1Tips
www.JDEE1Tips.com
 

Attachments

tot

Member
attach new logs

hi dear
Kindly find attach Install Action new one after Clear old Logs And RE Run Platform Install to recreate new Logs also NOT FOUND any logs for orcl
under path D:\JDEdwardsPPack\E920\inventory the path not include ORCL folder
and kindly find attach jde920_connection.doc to show successful connection
thanks for your support


Dear Tot,

Lets troubleshoot the issue. Please attach the installactions.log and ORCL log from the below location.

Install Action Log Directory : C:\Program Files (x86)\Oracle\Inventory\logs
ORCL Log Directory : C:\JDEdwardsPPack\E920_1\ORCL\logs

Check your DB JDE920 Installed correctly by following steps.

1. Try to ping DB using command "tnsping JDE920"
2. Try to login into DB using SYS userid by using below command

cmd> Sqlplus
username:sys@JDE920 as sysdba
Password:<DB sys/system Password>

Hope we will be able to help you!!!

Best Regards
JDEE1Tips
www.JDEE1Tips.com
 

Attachments

JDEE1Tips

Well Known Member
hi dear
Kindly find attach Install Action new one after Clear old Logs And RE Run Platform Install to recreate new Logs also NOT FOUND any logs for orcl
under path D:\JDEdwardsPPack\E920\inventory the path not include ORCL folder
and kindly find attach jde920_connection.doc to show successful connection
thanks for your support
Dear Tot,

We checked the log and found that , OUI Installer is not able to connect to your Oracle DB JDE920. Please see the below log file.

INFO: Exception occured during spawning :Cannot run program "D:\WinPPack\ORCL\TestRoleExistsOracle.bat": CreateProcess error=2, The system cannot find the file specified
INFO:
Query Exception: SpawnSysCmdQuery_RuntimeException
Query Exception Class: class oracle.sysman.oii.oiil.OiilQueryException
INFO: *** Cancel Dialog: Cannot spawn command. %1% ***
INFO: User Selected: Stop installation of all products.

1. Whether you downloaded the below DB component (V77465-01.zip) for oracle and Extracted into your extracted Enterprise server setup file (V77458-01.zip)?

V77458-01.zipJD Edwards EnterpriseOne 9.2 Platform Pack Windows
V77465-01.zipJD Edwards EnterpriseOne 9.2 Database Component for Oracle Database

2. Check your setup file whether you have TestRoleExistsOracle.bat under location D:\WinPPack\ORCL

Best Regards
JDEE1Tips
www.JDEE1Tips.com
 

tot

Member
Hi JDEE1Tips Team
Thanks for support your right i forget to add Database Component V77465-01.zip on D:\WinPPack\ i note the same "D:\WinPPack\ORCL\TestRoleExistsOracle.bat": not
have ORCL
THE FIX BY ADD ORCL UNDER D:\WinPPack\ AND IT COMPLETE INSTALL SUCCESSFUL
BUT WHEN I RUN PORTTEST JDE JDE PY920
I get this massage

D:\JDEdwardsPPack\E920\system\bin32>PORTTEST JDE JDE PY920
Running porttest for JDE on PY920,...

Initializing Environment PY920,...
Initialization of environment failed - rcode = 0
See host services check-list for details.

Porttest failed.
See the host services check-list for details.

All Done!

i have confusion if i install platform pack and database 12c on same machine and same drive d:\ for example
do i need to install client32bit ??????? on same drive d:\ for example
i will attach logs for more clarification




Dear Tot,

We checked the log and found that , OUI Installer is not able to connect to your Oracle DB JDE920. Please see the below log file.

INFO: Exception occured during spawning :Cannot run program "D:\WinPPack\ORCL\TestRoleExistsOracle.bat": CreateProcess error=2, The system cannot find the file specified
INFO:
Query Exception: SpawnSysCmdQuery_RuntimeException
Query Exception Class: class oracle.sysman.oii.oiil.OiilQueryException
INFO: *** Cancel Dialog: Cannot spawn command. %1% ***
INFO: User Selected: Stop installation of all products.

1. Whether you downloaded the below DB component (V77465-01.zip) for oracle and Extracted into your extracted Enterprise server setup file (V77458-01.zip)?

V77458-01.zipJD Edwards EnterpriseOne 9.2 Platform Pack Windows
V77465-01.zipJD Edwards EnterpriseOne 9.2 Database Component for Oracle Database

2. Check your setup file whether you have TestRoleExistsOracle.bat under location D:\WinPPack\ORCL

Best Regards
JDEE1Tips
www.JDEE1Tips.com
 

Attachments

JDEE1Tips

Well Known Member
Hi JDEE1Tips Team
Thanks for support your right i forget to add Database Component V77465-01.zip on D:\WinPPack\ i note the same "D:\WinPPack\ORCL\TestRoleExistsOracle.bat": not
have ORCL
THE FIX BY ADD ORCL UNDER D:\WinPPack\ AND IT COMPLETE INSTALL SUCCESSFUL
BUT WHEN I RUN PORTTEST JDE JDE PY920
I get this massage

D:\JDEdwardsPPack\E920\system\bin32>PORTTEST JDE JDE PY920
Running porttest for JDE on PY920,...

Initializing Environment PY920,...
Initialization of environment failed - rcode = 0
See host services check-list for details.

Porttest failed.
See the host services check-list for details.

All Done!

i have confusion if i install platform pack and database 12c on same machine and same drive d:\ for example
do i need to install client32bit ??????? on same drive d:\ for example
i will attach logs for more clarification
Dear Tot,

Just now saw your update!!!

Glad to hear from you,Enterprise Server installation was successful.

Please check the below points,

1. Porttest needs to be run from the command prompt using run as administrator option

2. Whether your "JDE E920 B9 Network" services owner is changed to windows user ID JDE?

3. You can verify the installactions.log if everything looks fine. Please ignore the porttest result as of now.

After doing full package you can re run the porttest, mostly it will be successful.

Best Regards
JDEE1Tips
www.JDEE1Tips.com
 
Top