Copy of P4210

jberry

Member
List,
I made a copy of P4210 and made minor changes to the program. The problem I am having is as follows:

There seems to be a business function that is called to retreive the Processing options and it looks at P4210 instead of my new program name. When I copied the program I did NOT copy the attached Processing Option. Would that fix the problem?

Example:
P574210 was copied from P4210
Version jab0001 in P574210 has product allocation turned on
Version jab0001 in P4210 does not have product allocation turned on.

When I run the program P574210 product allocation does not work. But if I change the P4210 version to allow Product allocation it starts working.

Has anyone else had this problem.

OW XE SP16 AS/400 Windows NT
Jimmy
 

Ekeck

Member
did you Create the processing options for P574210?



jberry
<[email protected]> To: [email protected]
Sent by: cc:
[email protected] Subject: Copy of P4210
delist.com


09/20/2001 10:56
AM
Please respond
to jdeowdev






List,
I made a copy of P4210 and made minor changes to the program. The problem
I am having is as follows:

There seems to be a business function that is called to retreive the
Processing options and it looks at P4210 instead of my new program name.
When I copied the program I did NOT copy the attached Processing Option.
Would that fix the problem?

Example:
P574210 was copied from P4210
Version jab0001 in P574210 has product allocation turned on
Version jab0001 in P4210 does not have product allocation turned on.

When I run the program P574210 product allocation does not work. But if I
change the P4210 version to allow Product allocation it starts working.

Has anyone else had this problem.

OW XE SP16 AS/400 Windows NT
Jimmy


--------------------------
Visit the forum to view this thread at:
http://198.144.193.139/cgi-bin/wwwthreads/showflat.pl?Cat
=&Board=OWDEV&Number=21119
+ - - - - - - - - - - - - - - - - - - - - - - - -+
This is the JDEList One World / XE Developers mailing list / forum.
Archives and information on how to SUBSCRIBE, and
UNSUBSCRIBE can be found on the JDEList Forum at
http://www.JDEList.com
+ - - - - - - - - - - - - - - - - - - - - - - - -+
 

jberry

Member
I did not change or copy the processing options when I copied the P4210 Program. When coping the P4210 it gives you the option to copy PO template. I did not do this. Should I ??

Jimmy
 

bondlela

Active Member
I always copy the Processing Option template whenever I copy a object with a
processing Options. If we donot copy the template during the copy process
then the object would still be using the existing PO template of the copied
object.

If you do not want the new object to use the PO template then you need to
change the ER where ever the PO template variables are referred.

Hope this helps.

Sailaja






bondlela
 

JoanneW

Member
We had the same problem. We have about 30 versions for P554210 and we just duplicated the versions for P4210. There are business functions that are looking at the P4210 processing option, so unless you want to find and change all of the business functions too, I would just duplicate the versions in the P4210. I works fine for us.

Joanne
One World Developer
B733.1 sp 14.2
AS400 coexistant
 

Paul_Pannu

Member
Jimmy,

Yes I had this problem with B732.1. P4210 relies heavily on the Master
business function. Within one of the C business functions it is hard coded
to look at the P4210 Processing option. The version is passed to the
business function whilst the object is hard coded. Even if you copy the
object it does not refer to the copied processing option.

There are two simple solutions to solving this problem. Have the same
version setup on P4210 and P574210. Or you may want to change the hard
coding of the business function to P574210.

Both these solutions may not be ideal for your requirements. I can not
remember how we solved the problem. But it may have been to pass the
Application name into the Business function (preventing hard coding) or
creating two copies of the business function.

Paul

OW B733 SQL Server
 
Top