Cannot create new item, says number already exists but search comes up empty

fr.agile

Member
I'm trying to enter a new part through the Item Master. I get error 0002, "The record being processed either already exists for an 'ADD' function or does not exist for an 'INQUIRY', 'CHANGE' or 'DELETE' function." But when I search for the part number, no results are found.

I've used this process to create part numbers before, recently, with no problem, and I've confirmed that others in the building with higher permissions levels are also unable to find this part. What are my options here?

Thanks in advance!
 

Aarto

Reputable Poster
I'm trying to enter a new part through the Item Master. I get error 0002, "The record being processed either already exists for an 'ADD' function or does not exist for an 'INQUIRY', 'CHANGE' or 'DELETE' function." But when I search for the part number, no results are found.

I've used this process to create part numbers before, recently, with no problem, and I've confirmed that others in the building with higher permissions levels are also unable to find this part. What are my options here?

Thanks in advance!

Howdy!
There are 3 fields which are all unique identifiers and all these must be unique for each item
Short item number - ITM
2nd item number - LITM
3rd item number - AITM

Short item number is usually assigned by next number but you can also override this value. 3rd item number is usually copied from 2nd item number unless overridden

Do a search in item master table with all 3 keys to see if an item master record already exists for any of the values (the assigned short item number is populated when you click OK and see the error messages) and i am quite sure you will find the record which has the same key as your new item

Hope this helps
Aarto
 

mansat1

Member
Not sure if you found out the problem. But one thing to check is - Run some SQL queries on the database and see if the item already exists in the table, but with special characters at the end of it; such as a newline character or a funny square box etc.
If that is the case, your JDE lookup will fail and it wont let you create new item?

Manish
 

luckyvicky

Member
Matrix Items are suppressed on the Item Browse application P4101, that may be one reason you are not seeing it. Check in database if the Item exists.
 
Top