Calling JDEdwards 9.1 from .net C#?

Hi, i am pretty new to JDEdwards integration to C#. We have JDEdwards version 9.1. I am working on ASP.NET application and need to query tables and also call business function from JDE system.

1) Can someone tell me which .net driver i need to download?
2) Also, can you share any sample code or connection strings??

Thanks.

Sanjeev
 

Rauf

VIP Member
Hi Sanjeev,

I was in the same situation 3 years ago. I am a migrant from .NET world to JDE.
Firstly, you have to understand about JDE is, every object(Data Item, UDC etc) have scope inside the JDE. It is not a general platform like .NET. Hence we cannot create a website or an image processing application in JDE. JDE only can understand the world like HR, Procurement, Finance etc :)

Check with your CNC to get the connection string to your data base. But it is not as easy as .NET. You may find a jargon code F0101 instead of Address Book Master table. Do you think you can guess the column ABAN8 is stands for Address Number, and ABALPH is for Name.

Also you can connect with me anytime.
 

jdelisths

Reputable Poster
Hi Sanjeev,

If you want to query data directly (i.e. without using JDE row security), it is pretty straightforward, as described here: https://msdn.microsoft.com/en-us/library/ms178371(v=vs.100).aspx. If you need to use JDE security and call business functions, there are several options: XML call object, Business Services (java) etc. Refer to the E1 interoperability guide for more information. For a native .NET option, consider LynX Business Integrator - it is Oracle Validated. Links:


http://www.aellius.com/products/lynx-business-integrator/
https://www.youtube.com/watch?v=3GJjhEeHe_Q
 

Stewart Schatz

Well Known Member
Hey, guys. You may also want to take a look at E1 Business Services. It's a much safer way to interface with E1 rather than hitting the database directly.
 
I tried to query database using this code:

using (OracleCommand cmd = new OracleCommand())
{
cmd.Connection = conn;
cmd.CommandText = "SELECT * FROM " + _pyLibrary + ".F4211 WHERE SDKCOO = '00005'";


cmd.CommandType = CommandType.Text;


using (OracleDataReader dr = cmd.ExecuteReader())
{
while (dr.Read())
{
string value1 = dr["SDKCOO"].ToString();
}
}
}

Everything works however 'dr.Read()' is always false and i cannot get any data back. The query is supposed to return valid data back.
Any clue why OracleDataReader is not returning any data?

Thanks.
 

jdelisths

Reputable Poster
There is nothing wrong with your code (I verified it on our instance). Check if there is any data for company key 00005 in your database using SQL*Plus.
 
Tried the query in SQL Developer and it returned no result. You guys were right there were no data on the database for that query. When i changed the query for valid SDKCOO value, it returned the value.
Now need to figure out if i can call Business Function without using third party tool. :)


Thanks.
 

proxybon

Member
Hi, What library references do we need to add in visual studio to connect to JDE simulator and pass values to simulator... any idea?
 
Top