C BSFN .....

kiant

Member
Larry,

It's VC++ 6.0. Service pack .........I donno where to find it. But it's VC++ 6.0 enterprise edition. Where do you find the SP info?

kiant
 

Wkunneke

Active Member
I don't think there is a way to determine which SP level you are on aside from comparing DLL date/time stamps. It's easy enough to apply the latest SP on MS Visual Studio though, go to http://msdn.microsoft.com/vstudio/sp/vs6sp5/default.asp
and it will walk you through it. Be forewarned, this is a MS Service Pack so be prepared for a few reboots to get it installed on your work station! :)

My CNC guy and a consultant (working on the Xe upgrade right now) both warned me that there are issues with SP 4 and 5 of Visual Studio. As for me, I've got SP 3 applied and plan to stay there unless there are some compelling reasons not to. According to the Knowledge Garden (yes, I did a bit of homework on this) the minimum technical requirements are SP 3. Hope this helps.

Live: B733.1 SP7.1
Oracle 805 AS400/DB2
Sandbox: XE SP15
Migrating Central Objects to AS400/DB2
 

Larry_Jones

Legendary Poster
Determining VS Service pack level - from the MSDN Library:
-------------------------------------------------------------
The About dialog box, which you can access from the Help menu, shows the initial version number of the product that is installed. It does not change when you install a service pack.

To determine if a service pack has been installed on a particular computer, find one of the files for the appropriate Microsoft developer product and check the version number. If the version number matches the number in the service pack column in the following table, then the service pack has been installed.

The table does not include a complete list of files, but rather it shows a representative sample of the changes from initial product release to each service pack. Note that for several products, there were no changes in versions for some files with some of the service packs.


Visual Studio 6.0 Release Service Pack 1 Service Pack 2 Service Pack 3 Service Pack 4
File Name Version Version Version Version Version

Oleaut32.dll 2.30.4261 2.30.4265 2.40.4268 2.40.4275.1 2.40.4277
Olepro32.dll 5.00.4261 5.00.4265 5.00.4268 5.0.4275.1 5.0.4277
Asycfilt.dll 2.30.4261 2.30.4265 2.40.4268 2.40.4275.1 2.40.4277
Stdole2.tlb 2.30.4261 2.30.4265 2.40.4268 2.40.4275.1 2.40.4277



Visual C++ 6.0 Release Service Pack 1 Service Pack 2 Service Pack 3 Service Pack 4
File Name Version Version Version Version Version

Mfc42.dll 6.00.8168.0 6.00.8267.0 Unchanged 6.0.8447.0 6.00.8665.0
Mfc42d.dll 6.00.8168.0 6.00.8267.0 Unchanged 6.0.8447.0 6.00.8665.0
Mfc42u.dll 6.00.8168.0 6.00.8267.0 Unchanged 6.0.8447.0 6.00.8665.0
Mfc42ud.dll 6.00.8168.0 6.00.8267.0 Unchanged 6.0.8447.0 6.00.8665.0
Mfcd42d.dll 6.00.8168.0 6.00.8267.0 Unchanged 6.0.8447.0 6.00.8665.0
Mfcd42ud.dll 6.00.8168.0 6.00.8267.0 Unchanged 6.0.8447.0 6.00.8665.0
Mfcn42d.dll 6.00.8168.0 6.00.8267.0 Unchanged 6.0.8447.0 6.00.8665.0
Mfcn42ud.dll 6.00.8168.0 6.00.8267.0 Unchanged 6.0.8447.0 6.00.8665.0
Mfco42d.dll 6.00.8168.0 6.00.8267.0 Unchanged 6.0.8447.0 6.00.8665.0
Mfco42ud.dll 6.00.8168.0 6.00.8267.0 Unchanged 6.0.8447.0 6.00.8665.0
Msvcrt.dll 6.00.8168.0 6.00.8267.0 6.00.8337.0 6.0.8397.0 6.00.8797.0
Msvcrtd.dll 6.00.8168.0 6.00.8267.0 6.00.8337.0 6.0.8447.0 6.00.8797.0



Larry Jones
ljones@wagstaff.com
OneWorld B733.1, SP 11.3
HPUX 11, Oracle SE 8.1.6
SandBox: OneWorld XE SP13
 

Zoltan_Gyimesi

Legendary Poster
Hi Kiant,

To be on the safe side, could be useful to check the related jde.ini settings on your machine ([JDE_CG] section). I copy this piece of mine but consider that my C++ installation isn't in the default place.
If yours is there then replace "C:\msdev\" with "C:\Program Files\Microsoft Visual Studio\"
======================================================================
[JDE_CG]
STDLIBDIR=C:\msdev\VC98\lib
TPLNAME=EXEFORM2
ERRNAME=CGERR
TARGET=Optimize
INCLUDES=C:\msdev\VC98\include;$(SYSTEM)\include;$(SYSTEM)\cg;$(APP)\include;$(SYSTEM)\includev
LIBS=C:\msdev\VC98\lib;$(SYSTEM)\lib32;$(APP)\lib32;$(SYSTEM)\libv32
MAKEDIR=C:\msdev\VC98\bin;C:\msdev\Common\MSDev98\Bin
USER=JDE
======================================================================
Good luck,
Zoltán

B7332 SP11, ESU 4116422, Intel NT4, SQL 7 SP1
(working with B7321, B7331, XE too)
 

kiant

Member
Hi Zoltan,

Here's what my .ini settings look like :

[JDE_CG]
STDLIBDIR=D:\Program Files\Microsoft Visual Studio\VC98\lib
TPLNAME=EXEFORM2
ERRNAME=CGERR
TARGET=Optimize
INCLUDES=D:\Program Files\Microsoft Visual Studio\VC98\include;$(SYSTEM)\include;$(SYSTEM)\cg;$(APP)\include;$(SYSTEM)\includev
LIBS=D:\Program Files\Microsoft Visual Studio\VC98\lib;$(SYSTEM)\lib32;$(APP)\lib32;$(SYSTEM)\libv32
MAKEDIR=D:\Program Files\Microsoft Visual Studio\VC98\bin;D:\Program Files\Microsoft Visual Studio\Common\MSDev98\Bin
USER=JDE

I guess they are fine coz I had installed VC b4 i installed oneworld, so the paths get set properly and thats how it's recommended by JD.

Some how i am not too optimistic about XE DEMO....

I am trying........

kiant

XE Demo
 

kiant

Member
Hey Larry.........

I am at service pack 1. Thanks much letting me know.

Now that I am at SP1. & XE Demo, is that an issue?
Do i need to install SP3 or 4 or 5???

kiant
 

Larry_Jones

Legendary Poster
Kiant,
SP 3 is reccommended. As was previously mentioned SP 4 has problems. I don't know anything about SP 5.

Did you check your jde.ini settings per Zoltan's suggestion?

Others,
Has anyone tried doing BSFN development on a demo before?

Larry Jones
ljones@wagstaff.com
OneWorld B733.1, SP 11.3
HPUX 11, Oracle SE 8.1.6
SandBox: OneWorld XE SP13
 

Zoltan_Gyimesi

Legendary Poster
Kiant,

We are on SP 3 level and work fine although my installation is a fat client, not a standalone DEMO.

Zoltán

B7332 SP11, ESU 4116422, Intel NT4, SQL 7 SP1
(working with B7321, B7331, XE too)
 

kiant

Member
Hi Larry,

I did check the JDE.ini settings as per Zoltan suggested. Also I have posted a message in it's reply. I guess they are fine.

You are right.......Basic question everyone...."Has anyone tried writing/building BSFN on XE Demo with VC SP less than 3?????"

kiant

XE Demo
 

kiant

Member
This is what my buildlog looks like, after which I get the error message mentioned in my earlier post. Also shows MFC2.dll error...

Generating Makefile: d:\B7\DEMO\obj\CALLBSFN.mak

Makefile generated.



Building business functions.



************CALLBSFN************



jdertdll.c

Creating library d:\B7\DEMO\lib32\CALLBSFN.lib and object d:\B7\DEMO\lib32\CALLBSFN.exp

LINK : warning LNK4005: no objects used from library D:\Program Files\Microsoft Visual Studio\VC98\lib\gdi32.lib

LINK : warning LNK4005: no objects used from library D:\Program Files\Microsoft Visual Studio\VC98\lib\shell32.lib

LINK : warning LNK4005: no objects used from library D:\Program Files\Microsoft Visual Studio\VC98\lib\comdlg32.lib

LINK : warning LNK4005: no objects used from library d:\B7\system\lib32\jdbodbc.lib

LINK : warning LNK4005: no objects used from library d:\B7\system\lib32\jdesetup.lib

LINK : warning LNK4005: no objects used from library d:\B7\system\lib32\jdegbr.lib

LINK : warning LNK4005: no objects used from library d:\B7\system\lib32\jdeoblib.lib

LINK : warning LNK4005: no objects used from library D:\Program Files\Microsoft Visual Studio\VC98\lib\odbc32.lib

LINK : warning LNK4005: no objects used from library d:\B7\system\lib32\jdedia.lib

LINK : warning LNK4005: no objects used from library d:\B7\system\lib32\jdedia1.lib

LINK : warning LNK4005: no objects used from library d:\B7\system\lib32\jdemail.lib

LINK : warning LNK4005: no objects used from library d:\B7\system\lib32\envtool.lib

LINK : warning LNK4005: no objects used from library d:\B7\system\lib32\browser.lib

LINK : warning LNK4005: no objects used from library d:\B7\system\lib32\jdepkgbld.lib

LINK : warning LNK4005: no objects used from library d:\B7\system\lib32\jdesetuputil.lib

LINK : warning LNK4005: no objects used from library d:\B7\system\lib32\jdeomw.lib

LINK : warning LNK4005: no objects used from library d:\B7\system\lib32\owver.lib

LINK : warning LNK4005: no objects used from library d:\B7\system\lib32\jdemtdeploy.lib

LINK : warning LNK4005: no objects used from library D:\Program Files\Microsoft Visual Studio\VC98\lib\uuid.lib



kiant
xe demo
 

franck_blettner

Active Member
I've developpe BSFN with XE demo with SP less than 3 and i've this problem.
Coul you check if you have in the directory lib32 a sCALLBSFN.lib file.
Because sometimes this file is named sCALLBSF.lib and it don't works. You
can just rename this file.

Franck

XE DEMO
B7332 SP15 RS6000

-----Message d'origine-----
De : owner-jdeowdevml@jdelist.com
[mailto:eek:wner-jdeowdevml@jdelist.com]De la part de kiant
Envoyé : jeudi 12 avril 2001 17:36
À : jdeowdevml@jdelist.com
Objet : Re: C BSFN .....


This is what my buildlog looks like, after which I get the error message
mentioned in my earlier post. Also shows MFC2.dll error...

Generating Makefile: d:\B7\DEMO\obj\CALLBSFN.mak

Makefile generated.



Building business functions.



************CALLBSFN************



jdertdll.c

Creating library d:\B7\DEMO\lib32\CALLBSFN.lib and object
d:\B7\DEMO\lib32\CALLBSFN.exp

LINK : warning LNK4005: no objects used from library D:\Program
Files\Microsoft Visual Studio\VC98\lib\gdi32.lib

LINK : warning LNK4005: no objects used from library D:\Program
Files\Microsoft Visual Studio\VC98\lib\shell32.lib

LINK : warning LNK4005: no objects used from library D:\Program
Files\Microsoft Visual Studio\VC98\lib\comdlg32.lib

LINK : warning LNK4005: no objects used from library
d:\B7\system\lib32\jdbodbc.lib

LINK : warning LNK4005: no objects used from library
d:\B7\system\lib32\jdesetup.lib

LINK : warning LNK4005: no objects used from library
d:\B7\system\lib32\jdegbr.lib

LINK : warning LNK4005: no objects used from library
d:\B7\system\lib32\jdeoblib.lib

LINK : warning LNK4005: no objects used from library D:\Program
Files\Microsoft Visual Studio\VC98\lib\odbc32.lib

LINK : warning LNK4005: no objects used from library
d:\B7\system\lib32\jdedia.lib

LINK : warning LNK4005: no objects used from library
d:\B7\system\lib32\jdedia1.lib

LINK : warning LNK4005: no objects used from library
d:\B7\system\lib32\jdemail.lib

LINK : warning LNK4005: no objects used from library
d:\B7\system\lib32\envtool.lib

LINK : warning LNK4005: no objects used from library
d:\B7\system\lib32\browser.lib

LINK : warning LNK4005: no objects used from library
d:\B7\system\lib32\jdepkgbld.lib

LINK : warning LNK4005: no objects used from library
d:\B7\system\lib32\jdesetuputil.lib

LINK : warning LNK4005: no objects used from library
d:\B7\system\lib32\jdeomw.lib

LINK : warning LNK4005: no objects used from library
d:\B7\system\lib32\owver.lib

LINK : warning LNK4005: no objects used from library
d:\B7\system\lib32\jdemtdeploy.lib

LINK : warning LNK4005: no objects used from library D:\Program
Files\Microsoft Visual Studio\VC98\lib\uuid.lib



kiant
xe demo



--------------------------
Visit the forum to view this thread at:
http://198.144.193.139/cgi-bin/wwwthreads/showflat.pl?Cat=&Board=OWDEV&Numbe
r=9065


Franck BLETTNER
Service Informatique RAVATE
Tel : 02 62 90 40 48
E-mail : franck.blettner@ravate.com
 

franck_blettner

Active Member
RE: RE: C BSFN .....

If you don't have these directories, it's because you don't have install you
XE DEMO in developpment. Try to reinstall your XE Standalone

-----Message d'origine-----
De : owner-jdeowdevml@jdelist.com
[mailto:eek:wner-jdeowdevml@jdelist.com]De la part de kiant
Envoyé : vendredi 13 avril 2001 00:29
À : jdeowdevml@jdelist.com
Objet : Re: RE: C BSFN .....


Chandu,

I do have those directories on the Box.

kiant



--------------------------
Visit the forum to view this thread at:
http://198.144.193.139/cgi-bin/wwwthreads/showflat.pl?Cat=&Board=OWDEV&Numbe
r=9095


Franck BLETTNER
Service Informatique RAVATE
Tel : 02 62 90 40 48
E-mail : franck.blettner@ravate.com
 

Zoltan_Gyimesi

Legendary Poster
Hi Kiant,

1.) You have to install a FULL Package (instead of Partial) to install development objects too, so to have "source", "include", "make", "work" etc. subfolders in your path-code subfolder under "b7" folder.

2.) Try to create a new custom DLL (BL type object) and designate this DLL for your new custom BSFN. First time to build it choose "BusBuild Standalone" on the Design Tools tab after you choosed Design for your BSFN in the OMW.
* select Build All from Build menu
* mark Select specific DLL to Build check box
* press Select
* press Clear All and select your BSFN, press OK
* press Build

Happy Easter Holidays!

Zoltán

B7332 SP11, ESU 4116422, Intel NT4, SQL 7 SP1
(working with B7321, B7331, XE too)
 

kiant

Member
Hi Zoltan/ Franck,

Franck, I do have the CALLBSFN.lib and CALLBSFN.exp in my \demo\lib32.
Zoltan, I am sure I have installed the dev objects too and I have the work, include , source directories with the .h, .c files.
I had liked the BSFN to CALLBSFN using standalone build, during which too i get error.

Still trying...

Happy Easter everyone...

kiant
 

Zoltan_Gyimesi

Legendary Poster
Hi Kiant,

1.) Do you have an "sCALLBSF.lib" file in your bin32 subfolder? Listen: NOT sCALLBSFN.lib!!!! If the name is the second then shorten it with the last N letter and try again.

2.) Try to build the whole CALLBSFN.DLL using the same way that I have described in my previous post for first build of custom DLL.

Good luck
&
Happy Easter Holiday!

Zoltán

B7332 SP11, ESU 4116422, Intel NT4, SQL 7 SP1
(working with B7321, B7331, XE too)
 

kiant

Member
Hi Zoltan,

Yes I do have sCALLBSF.lib too in my library !!!. So for CALLBSFN, I have 3 files in the library : CALLBSFN.LIB, CALLBSFN.EXP & sCALLBSF.LIB.

Now, do I need to have sCALLBSFN.LIB???

I will try building CALLBSFN till then..

Enjoy ur weekend and Easter....

kiant
XE demo
 

Zoltan_Gyimesi

Legendary Poster
Hi Kiant,
You do not need to have sCALLBSFN.LIB (only sCALLBSF.LIB).
Have rebuild CALLBSFN.DLL already? What was the result?
Zoltán

B7332 SP11, ESU 4116422, Intel NT4, SQL 7 SP1
(working with B7321, B7331, XE too)
 
Top